<!DOCTYPE html>
<html>
  <head>
    <meta charset="utf-8" />
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"02bf0a7962","applicationID":"131593373","transactionName":"dl4KRhNdXFwDQRhKUFlUFx0SWl9H","queueTime":0,"applicationTime":434,"agent":""}</script>
<script type="text/javascript">window.NREUM||(NREUM={}),__nr_require=function(e,t,n){function r(n){if(!t[n]){var o=t[n]={exports:{}};e[n][0].call(o.exports,function(t){var o=e[n][1][t];return r(o||t)},o,o.exports)}return t[n].exports}if("function"==typeof __nr_require)return __nr_require;for(var o=0;o<n.length;o++)r(n[o]);return r}({1:[function(e,t,n){function r(){}function o(e,t,n){return function(){return i(e,[f.now()].concat(u(arguments)),t?null:this,n),t?void 0:this}}var i=e("handle"),a=e(2),u=e(3),c=e("ee").get("tracer"),f=e("loader"),s=NREUM;"undefined"==typeof window.newrelic&&(newrelic=s);var p=["setPageViewName","setCustomAttribute","setErrorHandler","finished","addToTrace","inlineHit","addRelease"],d="api-",l=d+"ixn-";a(p,function(e,t){s[t]=o(d+t,!0,"api")}),s.addPageAction=o(d+"addPageAction",!0),s.setCurrentRouteName=o(d+"routeName",!0),t.exports=newrelic,s.interaction=function(){return(new r).get()};var m=r.prototype={createTracer:function(e,t){var n={},r=this,o="function"==typeof t;return i(l+"tracer",[f.now(),e,n],r),function(){if(c.emit((o?"":"no-")+"fn-start",[f.now(),r,o],n),o)try{return t.apply(this,arguments)}catch(e){throw c.emit("fn-err",[arguments,this,e],n),e}finally{c.emit("fn-end",[f.now()],n)}}}};a("setName,setAttribute,save,ignore,onEnd,getContext,end,get".split(","),function(e,t){m[t]=o(l+t)}),newrelic.noticeError=function(e){"string"==typeof e&&(e=new Error(e)),i("err",[e,f.now()])}},{}],2:[function(e,t,n){function r(e,t){var n=[],r="",i=0;for(r in e)o.call(e,r)&&(n[i]=t(r,e[r]),i+=1);return n}var o=Object.prototype.hasOwnProperty;t.exports=r},{}],3:[function(e,t,n){function r(e,t,n){t||(t=0),"undefined"==typeof n&&(n=e?e.length:0);for(var r=-1,o=n-t||0,i=Array(o<0?0:o);++r<o;)i[r]=e[t+r];return i}t.exports=r},{}],4:[function(e,t,n){t.exports={exists:"undefined"!=typeof window.performance&&window.performance.timing&&"undefined"!=typeof window.performance.timing.navigationStart}},{}],ee:[function(e,t,n){function r(){}function o(e){function t(e){return e&&e instanceof r?e:e?c(e,u,i):i()}function n(n,r,o,i){if(!d.aborted||i){e&&e(n,r,o);for(var a=t(o),u=m(n),c=u.length,f=0;f<c;f++)u[f].apply(a,r);var p=s[y[n]];return p&&p.push([b,n,r,a]),a}}function l(e,t){v[e]=m(e).concat(t)}function m(e){return v[e]||[]}function w(e){return p[e]=p[e]||o(n)}function g(e,t){f(e,function(e,n){t=t||"feature",y[n]=t,t in s||(s[t]=[])})}var v={},y={},b={on:l,emit:n,get:w,listeners:m,context:t,buffer:g,abort:a,aborted:!1};return b}function i(){return new r}function a(){(s.api||s.feature)&&(d.aborted=!0,s=d.backlog={})}var u="nr@context",c=e("gos"),f=e(2),s={},p={},d=t.exports=o();d.backlog=s},{}],gos:[function(e,t,n){function r(e,t,n){if(o.call(e,t))return e[t];var r=n();if(Object.defineProperty&&Object.keys)try{return Object.defineProperty(e,t,{value:r,writable:!0,enumerable:!1}),r}catch(i){}return e[t]=r,r}var o=Object.prototype.hasOwnProperty;t.exports=r},{}],handle:[function(e,t,n){function r(e,t,n,r){o.buffer([e],r),o.emit(e,t,n)}var o=e("ee").get("handle");t.exports=r,r.ee=o},{}],id:[function(e,t,n){function r(e){var t=typeof e;return!e||"object"!==t&&"function"!==t?-1:e===window?0:a(e,i,function(){return o++})}var o=1,i="nr@id",a=e("gos");t.exports=r},{}],loader:[function(e,t,n){function r(){if(!x++){var e=h.info=NREUM.info,t=d.getElementsByTagName("script")[0];if(setTimeout(s.abort,3e4),!(e&&e.licenseKey&&e.applicationID&&t))return s.abort();f(y,function(t,n){e[t]||(e[t]=n)}),c("mark",["onload",a()+h.offset],null,"api");var n=d.createElement("script");n.src="https://"+e.agent,t.parentNode.insertBefore(n,t)}}function o(){"complete"===d.readyState&&i()}function i(){c("mark",["domContent",a()+h.offset],null,"api")}function a(){return E.exists&&performance.now?Math.round(performance.now()):(u=Math.max((new Date).getTime(),u))-h.offset}var u=(new Date).getTime(),c=e("handle"),f=e(2),s=e("ee"),p=window,d=p.document,l="addEventListener",m="attachEvent",w=p.XMLHttpRequest,g=w&&w.prototype;NREUM.o={ST:setTimeout,SI:p.setImmediate,CT:clearTimeout,XHR:w,REQ:p.Request,EV:p.Event,PR:p.Promise,MO:p.MutationObserver};var v=""+location,y={beacon:"bam.nr-data.net",errorBeacon:"bam.nr-data.net",agent:"js-agent.newrelic.com/nr-1071.min.js"},b=w&&g&&g[l]&&!/CriOS/.test(navigator.userAgent),h=t.exports={offset:u,now:a,origin:v,features:{},xhrWrappable:b};e(1),d[l]?(d[l]("DOMContentLoaded",i,!1),p[l]("load",r,!1)):(d[m]("onreadystatechange",o),p[m]("onload",r)),c("mark",["firstbyte",u],null,"api");var x=0,E=e(4)},{}]},{},["loader"]);</script>
<title>
  The Python Power Coder BONUS Bundle | Digg Store
</title>
<link rel="alternate" type="application/rss+xml" title="RSS" href="https://store.digg.com/feed.rss" />
<meta name = "description" content = "The Python Power Coder Bonus Bundle: That&#39;s Right, A Bonus 31 Hours of Python Training to Broaden Your Career Horizons" >
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no">

<link rel="shortcut icon" type="image/x-icon" href="https://cdnp0.stackassets.com/9b64ebe5fb0bb6bb24781b0b26b2b576af694063/store/00fc99d4f0b1c99cd5be5aea8abb5c24d40ff1c80207fd50cb492af93eb1/favicon.png" />
<link rel="apple-touch-icon" type="image/x-icon" href="https://cdnp0.stackassets.com/9b64ebe5fb0bb6bb24781b0b26b2b576af694063/store/00fc99d4f0b1c99cd5be5aea8abb5c24d40ff1c80207fd50cb492af93eb1/favicon.png" />


<link href="//maxcdn.bootstrapcdn.com/font-awesome/4.2.0/css/font-awesome.min.css" rel="stylesheet">

  <link rel="stylesheet" media="all" href="https://shops2.stackassets.com/assets/classic-cfb694bb10f4d6e8a8db7367eeab8700c1c51bece6007ec8517dbdc491bab6a3.css" />
  <link rel="stylesheet" media="all" href="//fonts.googleapis.com/css?family=Open+Sans:300italic,400italic,600italic,700italic,400,300,600,700" />

<style>.publisher-digg .brand-primary,.publisher-digg .shopping-cart-icon.active,.publisher-digg .my-account-container .nav-tabs li a.active,.publisher-digg #sc-nyop-buttons .btn-default.active .fa-circle,.publisher-digg input[type=radio]:checked+label:before,.publisher-digg input[type=checkbox]:checked+label:before,.publisher-digg .footer .newsletter .btn-default,.publisher-digg .js-cart-item-remove:hover,.publisher-digg .mobile-search-icon.active .search-input-icon,.publisher-digg .search-input:focus+.search-input-icon{color:#00b0ff}@media (min-width: 992px){.publisher-digg .navbar-master .nav-item-container:hover .nav-item-link,.publisher-digg .navbar-master .nav-item-link:hover{border-color:#00b0ff;color:#00b0ff !important}}.publisher-digg #sc-nyop-leaderboard tr:first-child td:first-child strong,.publisher-digg .table>tbody>tr.active td,.publisher-digg .table>tbody>tr.active:hover td,.publisher-digg .sc-form-group .bar:before,.publisher-digg .sc-form-group .bar:after,.publisher-digg .checkout .edit-address-bar,.publisher-digg .footer-newsletter .btn-primary,.publisher-digg .navbar.navbar-master .dropdown-nav-switcher .nav-item-link,.publisher-digg .navbar.navbar-master .dropdown-nav-switcher.open .nav-item-link{background-color:#00b0ff}.publisher-digg .address-verification-modal .btn-primary{background-color:#00b0ff}.publisher-digg .address-verification-modal .btn-primary:hover{background-color:#009ee6}.publisher-digg .table-hover>tbody>tr:hover,.publisher-digg .active .shipping-address,.publisher-digg .active .billing-address{background-color:#dbf4ff}.publisher-digg .sc-product-thumbnails .product-thumbnail.active,.publisher-digg input[type=radio]:checked+label:before,.publisher-digg input[type=checkbox]:checked+label:before,.publisher-digg .btn-selectable.active,.publisher-digg .active .shipping-address,.publisher-digg .active .billing-address{border-color:#00b0ff}.publisher-digg .hello-bar{background-color:#000000}.publisher-digg .hello-bar a{color:#FFFFFF}.publisher-digg .alert-notification{background-color:#000;border-color:#000;color:#fff}.publisher-digg .alert-notification hr{border-top-color:#000}.publisher-digg .alert-notification .alert-link{color:#e6e6e6}.publisher-digg .navbar-default,.publisher-digg .search-input,.publisher-digg .navbar-collapse{background-color:#FFFFFF}.publisher-digg .search-input-icon,.publisher-digg .shopping-cart-icon,.publisher-digg .navbar-default .navbar-nav>li>a,.publisher-digg .navbar-default .navbar-nav>li>a:hover,.publisher-digg .nav-item-link,.publisher-digg .dropdown-menu>li>a,.publisher-digg .dropdown-menu>li>a:hover,.publisher-digg .navbar-default .navbar-nav>.open>a{color:#000000}.publisher-digg .navbar-default .navbar-toggle .icon-bar{background-color:#000000}@media (max-width: 991px){.publisher-digg .menu-list>li>a,.publisher-digg .menu-list>li>.subnav-menu-label,.publisher-digg .menu-list .subnav-menu-items a,.publisher-digg .menu-list>li>a:hover{color:#000000;background:none}}.publisher-digg .navbar-toggle .icon-cart{font-size:1.7em}.publisher-digg .navbar-toggle .search-input-icon{font-size:1.4em}@media (max-width: 991px){.publisher-digg .navbar-default .nav-item,.publisher-digg .navbar-default .subnav-menu,.publisher-digg .navbar-default .subnav-menu-items{border:0;border-top:1px solid #aaa}.publisher-digg .navbar-default .nav-item.open{border-color:transparent}.publisher-digg .navbar-default .nav-item:first-child{border:0}}.publisher-digg .navbar-search .search-input,.publisher-digg .navbar-search-mobile .search-input{color:#000000;border:1px solid #aaa}.publisher-digg .shopping-cart-total .badge{background-color:#f41e37}.publisher-digg #sc-hero-unit{background-image:url("https://cdnp0.stackassets.com/057ed07159ad69d752e7f65dd277ecca5b059e14/store/88ddf5ce994e3ceceea3d8443d28147c71cd19293242d81da21a5b7fc496/21768836_10155104661553721_3687715984027438201_o.jpg")}.publisher-digg #sc-hero-unit.giveaway-no-banner{background-image:none}.primary-color{color:#00b0ff !important}.active.primary-border-color-active{border-color:#00b0ff !important}.primary-border-color-active:hover{border-color:#66d0ff !important}.primary-border-top{border-top-color:#00b0ff !important}.active.primary-border-top-active{border-top-color:#00b0ff !important}.primary-border-left{border-left-color:#00b0ff !important}.active.primary-border-left-active{border-left-color:#00b0ff !important}.primary-border-bottom{border-bottom-color:#00b0ff !important}.active.primary-border-bottom-active{border-bottom-color:#00b0ff !important}.primary-border-right{border-right-color:#00b0ff !important}.active.primary-border-right-active{border-right-color:#00b0ff !important}.buy-now-column .loyalty-callout{color:#00b0ff}.loyalty-callout--bar{background-color:#00b0ff}@media (min-width: 993px){.loyalty-callout--bar{background-color:#fff;color:#00b0ff}}
</style>

<script src="https://ajax.googleapis.com/ajax/libs/jquery/2.1.3/jquery.min.js"></script>

<script>
  window['optimizely'] = window['optimizely'] || [];
  window['optimizely'].push(["customTag", "LoggedIn", false]);
</script>
<script src="//cdn.optimizely.com/js/74647825.js"></script>
<script src="https://shops2.stackassets.com/assets/shared-178e39bdb70b420a918ed588bf4172e270dc8aa76ed55b131ce6a9a30a39bf18.js"></script>
<!--[if lte IE 9]>
  <script src="https://shops2.stackassets.com/assets/jquery.html5-placeholder-shim-fd57d1a7d62d64d8cfd7af63ec58c8db8248e7709cac024b6946c984d31e9b7d.js"></script>
  <script>
    $.placeholder.shim();
  </script>
<![endif]-->

<script src="https://www.google.com/recaptcha/api.js" async="async" defer="defer"></script>
<script src="https://assets.jetlore.com/js/jlranker.js"></script>

  <meta name="twitter:card" content="product" />
<meta name="twitter:title" content="3 New, In-Depth Courses Bring This Python Bundle to 70 Resume-Enhancing Hours of Content" />
<meta name="twitter:description" content="The Python Power Coder Bonus Bundle: That&#39;s Right, A Bonus 31 Hours of Python Training to Broaden Your Career Horizons" />
<meta name="twitter:image:src" content="https://cdnp0.stackassets.com/3c302ea4405f551aac1a9120aa3841619e06bc24/store/49ffc815133767e1bf7e4367166b302e7a9ca80c2beb23a676d036973bef/sale_5556_primary_image.jpg" />
<meta name="twitter:data1" content="$44.00" />
<meta name="twitter:label1" content="PRICE" />
<meta name="twitter:data2" content="95%" />
<meta name="twitter:label2" content="OFF" />
<meta name="twitter:domain" content="store.digg.com" />
<meta name="twitter:site" content="@digg" />
<meta name="twitter:creator" content="@digg" />

<meta property="fb:app_id" content="468274286708621" />
<meta property="og:type" content="website" />
<meta property="og:description" content="The Python Power Coder Bonus Bundle: That&#39;s Right, A Bonus 31 Hours of Python Training to Broaden Your Career Horizons" />
<meta property="og:title" content="3 New, In-Depth Courses Bring This Python Bundle to 70 Resume-Enhancing Hours of Content" />
<meta property="og:image" content="https://cdnp0.stackassets.com/3c302ea4405f551aac1a9120aa3841619e06bc24/store/49ffc815133767e1bf7e4367166b302e7a9ca80c2beb23a676d036973bef/sale_5556_primary_image.jpg" />
<meta property="og:site_name" content="Digg Store" />
<meta property="og:url" content="https://store.digg.com/sales/the-python-power-coder-bonus-bundle?utm_source=digg.com&amp;utm_medium=referral&amp;utm_campaign=the-python-power-coder-bonus-bundle_070818&amp;utm_term=scsf-292671&amp;utm_content=a0x1a000003nfnL&amp;scsonar=1" />


<meta name="csrf-param" content="authenticity_token" />
<meta name="csrf-token" content="WwHCXBmct04ouGgkoRK9PTLhsTgzwZcBetc2GXiLj18fiJmxcDiHnsOqqOe1tJupZgiFLUbLOcZ6ZiHYge/xHA==" />


    <!-- Quantcast Tag, part 1 -->
    <script type="text/javascript">
      var _qevents = _qevents || [];
      (function() {
       var elem = document.createElement('script');
       elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
       elem.async = true;
       elem.type = "text/javascript";
       var scpt = document.getElementsByTagName('script')[0];
       scpt.parentNode.insertBefore(elem, scpt);
      })();
    </script>

    <script>
  !function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
  n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
  n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
  t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
  document,'script','//connect.facebook.net/en_US/fbevents.js');

  fbq('init', '675226672634286');
  fbq('track', "PageView");</script>
  <noscript><img height="1" width="1" style="display:none"
  src="https://www.facebook.com/tr?id=675226672634286&ev=PageView&noscript=1"
  /></noscript>


<script type="text/javascript">
  window.fbq = window.fbq || (function(){});
  window._fbq = window._fbq || [];
</script>

<script type="text/javascript">
  window.dataLayer = [{
    publisherId: '124',
    affiliateId: '',
    appEnvironment: 'production',
    showEmailCapture: 'true'
  }];

  window.SC.code.analytics = {
    customDimension: function(index, name, value) {
      gtmPayload = {};
      gtmPayload['dimension' + index] = value;
      dataLayer.push(gtmPayload);
    },

    analyticsEvent: function(category, action, opt_label, opt_value, opt_noninteractive) {
      // ensure value is integer. We encountered weird analytics behavior if decimals are sent
      integer_value = Math.round(opt_value) || undefined

      dataLayer.push({
        'event': 'analyticsEvent',
        'eventCategory': category,
        'eventAction': action,
        'eventLabel': opt_label,
        'eventValue': integer_value,
        'eventNonInt': opt_noninteractive
      });
    },

    analyticsSocial: function(socialNetwork, socialAction, opt_socialTarget, opt_page) {
      dataLayer.push({
        'event': 'social',
        'socialNetwork': socialNetwork,
        'socialAction': socialAction,
        'socialTarget': opt_socialTarget,
        'socialPagePath': opt_page
      });
    },

    analyticsVPV: function(virtualPageName) {
      dataLayer.push({
        'event': 'analyticsVPV',
        'vpvName': virtualPageName
      });
    },

    analyticsClearVPV: function() {
      dataLayer.push({
        'event': 'analyticsVPV',
        'vpvName': undefined
      });
    },

    analyticsForm: function(f, el) {
      var formName = f;
      var elName = el.name || el.id || el.type;
      var category = 'interaction';
      var action = 'form: ' + formName;
      var label = elName + ':' + el.type;

      // Google Tag Manager
      analyticsEvent(category, action, label);
    }
  };

  $(document).ready(function() {
    window.SC.dataLayer.enqueue('SCDataLayer', 'USER_VISITS', { previouslyPurchasedProducts: 'false' });


  });
</script>


  <link rel="canonical" href="https://stacksocial.com/sales/the-python-power-coder-bonus-bundle" />
<style>#sc-hero-unit { background-image:url(https://cdnp2.stackassets.com/6ad04c32ccd29ca666b1709c4cb9121676f3b6a3/store/3a20a8bdd6c4b856f9f076a334ffb25652e8a7c641f3f2aeccbbd67bffd4/sale_5556_special_sale_banner_background.jpg) !important }</style>

<script type="text/javascript">
var _user_id = '';
var _session_id = '0582d906fbdef8aa50c9873e51ba05de';

var _sift = window._sift = window._sift || [];
_sift.push(['_setAccount', 'ef01e3d959']);
_sift.push(['_setUserId', _user_id]);
_sift.push(['_setSessionId', _session_id]);
_sift.push(['_trackPageview']);
(function() {
  function ls() {
    var e = document.createElement('script');
    e.type = 'text/javascript';
    e.async = true;
    e.src = ('https:' === document.location.protocol ? 'https://' : 'http://') + 'cdn.siftscience.com/s.js';
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(e, s);
  }
  if (window.attachEvent) {
    window.attachEvent('onload', ls);
  } else {
    window.addEventListener('load', ls, false);
  }
})();
</script>


<input type="hidden" class="js-jetlore-constructor-tag" id="user_email" value="">

  </head>
  <body id="stacksocial-wrapper" class="publisher-digg" ng-app="stackApp" ng-class="[cartStateBodyClass]">
    <a href="https://iar40lbead.execute-api.us-east-1.amazonaws.com/ProdStage" rel="nofollow" style="display: none" aria-hidden="true">nofollow</a>
    <script type="text/javascript">
  // dimension1 is reserved for legacy PartnerType and is unused
  window.SC.code.analytics.customDimension(2, 'User Status', "logged_out");

    window.SC.code.analytics.customDimension(3, "Publisher", "Digg");
    window.SC.code.analytics.customDimension(4, "Publisher Persona", "Internet Culture");





</script>

    <!-- StackCommerce GTM Container -->
  <noscript>
    <iframe src="https://www.googletagmanager.com/ns.html?id=GTM-P2BQKM" height="0" width="0" style="display:none;visibility:hidden"></iframe>
  </noscript>
  <script>
    (function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
    new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
    j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
    'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
    })(window,document,'script','dataLayer','GTM-P2BQKM');
  </script>

    <input type="hidden" name="current_publisher" id="current_publisher" value="124" data-name="Digg" data-credit-upsell-id="9426" />
    <input type="hidden" name="current_user_favorites" id="current_user_favorites" data-sale-ids="[]" data-sales-url="https://store.digg.com/v0/sales" />
    <input type="hidden" name="api_url" id="api_url" value="https://store.digg.com/" />
    <input type="hidden" name="current_cart" id="current_cart" data-current-cart="{&quot;items&quot;:[]}" />
    <input type="hidden" name="publisher_upsell_sales" id="publisher_upsell_sales" data-sales="[{&quot;from_jetlore&quot;:true},{&quot;from_jetlore&quot;:true},{&quot;from_jetlore&quot;:true},{&quot;from_jetlore&quot;:true}]" data-max-quantity="4" />
    <?xml version="1.0" encoding="UTF-8"?>
<svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" display="none" version="1.1">
  <defs>
    <symbol id="icon-heart" viewBox="0 0 75 75">
      <path class="path1" d="M18,38.5L36.2,57c0.3,0.3,0.8,0.5,1.3,0.5c0.5,0,1-0.2,1.3-0.5l9.1-9.2c3-3.1,6.1-6.1,9.1-9.2c4.7-4.8,4.7-12.6,0-17.4c-2.3-2.3-5.4-3.6-8.7-3.6c-3.3,0-6.4,1.3-8.7,3.6l-2,2l-2-2.1c-2.3-2.3-5.4-3.6-8.7-3.6c-3.3,0-6.4,1.3-8.7,3.6C13.3,25.9,13.3,33.7,18,38.5z M20.7,23.5c1.7-1.7,3.8-2.6,6.1-2.6c2.3,0,4.4,0.9,6.1,2.6l3.4,3.4c0.3,0.3,0.8,0.5,1.3,0.5c0.5,0,1-0.2,1.3-0.5l3.3-3.4c1.7-1.7,3.8-2.6,6.1-2.6c2.3,0,4.4,0.9,6.1,2.6c3.4,3.5,3.4,9.1,0,12.6L37.5,53.2l-0.1-0.1l-16.7-17C17.3,32.6,17.3,27,20.7,23.5z" />
    </symbol>

    <symbol id="icon-circle-heart" viewBox="0 0 75 75">
      <path class="path1" d="M23.1,40.5 L36.525,54.6 C36.75,54.825 37.125,54.975 37.5,54.975 C37.875,54.975 38.25,54.825 38.475,54.6 L45.15,47.55 C47.4,45.225 49.65,42.825 51.825,40.5 C55.35,36.825 55.35,30.825 51.825,27.15 C50.1,25.35 47.85,24.375 45.375,24.375 C42.9,24.375 40.65,25.35 38.925,27.15 L37.425,28.725 L35.925,27.15 C34.2,25.35 31.95,24.375 29.475,24.375 C27,24.375 24.75,25.35 23.025,27.15 C19.65,30.9 19.65,36.825 23.1,40.5 Z M25.05,29.025 C26.25,27.75 27.9,27 29.55,27 C31.2,27 32.85,27.675 34.05,29.025 L36.525,31.65 C36.75,31.875 37.125,32.025 37.5,32.025 C37.875,32.025 38.25,31.875 38.475,31.65 L40.95,29.025 C42.15,27.75 43.8,27 45.45,27 C47.1,27 48.75,27.675 49.95,29.025 C52.5,31.65 52.5,36 49.95,38.7 L37.5,51.825 L37.425,51.675 L25.05,38.7 C22.5,36 22.5,31.725 25.05,29.025 Z"></path>
      <path class="path2" d="M37.5,74.625 C17.025,74.625 0.375,57.975 0.375,37.5 C0.375,17.025 17.025,0.375 37.5,0.375 C57.975,0.375 74.625,17.025 74.625,37.5 C74.625,57.975 57.975,74.625 37.5,74.625 Z M37.5,2.625 C18.3,2.625 2.625,18.3 2.625,37.5 C2.625,56.7 18.3,72.375 37.5,72.375 C56.7,72.375 72.375,56.7 72.375,37.5 C72.375,18.3 56.7,2.625 37.5,2.625 Z"></path>
    </symbol>

    <symbol id="icon-circle-heart-filled" viewBox="0 0 75 75">
      <path class="path1" d="M23.1,40.5 L36.525,54.6 C36.75,54.825 37.125,54.975 37.5,54.975 C37.875,54.975 38.25,54.825 38.475,54.6 L45.15,47.55 C47.4,45.225 49.65,42.825 51.825,40.5 C55.35,36.825 55.35,30.825 51.825,27.15 C50.1,25.35 47.85,24.375 45.375,24.375 C42.9,24.375 40.65,25.35 38.925,27.15 L37.425,28.725 L35.925,27.15 C34.2,25.35 31.95,24.375 29.475,24.375 C27,24.375 24.75,25.35 23.025,27.15 C19.65,30.9 19.65,36.825 23.1,40.5 Z"></path>
      <path class="path2" d="M37.5,74.625 C17.025,74.625 0.375,57.975 0.375,37.5 C0.375,17.025 17.025,0.375 37.5,0.375 C57.975,0.375 74.625,17.025 74.625,37.5 C74.625,57.975 57.975,74.625 37.5,74.625 Z M37.5,2.625 C18.3,2.625 2.625,18.3 2.625,37.5 C2.625,56.7 18.3,72.375 37.5,72.375 C56.7,72.375 72.375,56.7 72.375,37.5 C72.375,18.3 56.7,2.625 37.5,2.625 Z"></path>
    </symbol>

    <symbol id="icon-cart" viewBox="0 0 75 75">
      <path class="path1" d="M47.8,52.5c1.3,0,2.3,1,2.3,2.3c0,1.3-1,2.3-2.3,2.3s-2.3-1-2.3-2.3C45.5,53.5,46.5,52.5,47.8,52.5z M30.4,52.5c1.3,0,2.3,1,2.3,2.3c0,1.3-1,2.3-2.3,2.3c-1.3,0-2.3-1-2.3-2.3C28.1,53.5,29.1,52.5,30.4,52.5z M47.8,49.1c-3.2,0-5.8,2.6-5.8,5.8c0,3.2,2.6,5.8,5.8,5.8s5.8-2.6,5.8-5.8C53.6,51.7,50.9,49.1,47.8,49.1z M30.4,49.1c-3.2,0-5.8,2.6-5.8,5.8c0,3.2,2.6,5.8,5.8,5.8s5.8-2.6,5.8-5.8C36.2,51.7,33.6,49.1,30.4,49.1z M23.2,23.8h34.5L55,35.4l-26.3,2.1L23.2,23.8z M11.4,14.6c-1,0-1.7,0.8-1.7,1.7s0.8,1.7,1.7,1.7h5.8c2.9,7.1,5.7,14.2,8.5,21.2l-2.6,6.3c-0.2,0.5-0.2,1.2,0.2,1.6c0.3,0.5,0.9,0.8,1.4,0.8h28.9c0.9,0,1.8-0.8,1.8-1.7c0-0.9-0.8-1.7-1.8-1.7H27.3l1.5-3.6l27.8-2.2c0.7-0.1,1.4-0.6,1.6-1.3l3.5-15c0.2-1-0.7-2.1-1.7-2.1H21.8l-1.9-4.7c-0.3-0.6-0.9-1.1-1.6-1.1H11.4z" />
    </symbol>

    <symbol id="icon-search" viewBox="0 0 75 75">
      <path class="path1" d="M34.1,17.5c-4.4,0-8.6,1.7-11.7,4.9c-3.1,3.1-4.9,7.3-4.9,11.7c0,4.4,1.7,8.6,4.9,11.7c3.1,3.1,7.3,4.9,11.7,4.9c3.7,0,7.2-1.2,10.1-3.5l0.2-0.2l10,10c0.7,0.7,1.9,0.7,2.6,0c0.7-0.7,0.7-1.9,0-2.6v0l-10-10l0.2-0.2c5.1-6.6,4.5-16-1.4-21.9C42.6,19.2,38.5,17.5,34.1,17.5 M43.2,43.2c-2.4,2.4-5.7,3.8-9.1,3.8h0c-3.4,0-6.7-1.3-9.1-3.8c-2.4-2.4-3.8-5.7-3.8-9.1c0-3.4,1.3-6.7,3.8-9.1c2.4-2.4,5.7-3.8,9.1-3.8c3.4,0,6.7,1.3,9.1,3.8c2.4,2.4,3.8,5.7,3.8,9.1S45.6,40.7,43.2,43.2" />
    </symbol>

    <symbol id="icon-ships-fast" viewBox="0 0 100 100">
      <path class="st0" d="M30.1,39.2L30.1,39.2l-12.3,0c0,0,0,0,0,0c-0.3,0-0.7,0.1-0.9,0.4c-0.2,0.2-0.4,0.6-0.4,0.9
        c0,0.3,0.1,0.7,0.4,0.9c0.2,0.2,0.6,0.4,0.9,0.4l12.3,0c0.4,0,0.7-0.1,0.9-0.4c0.3-0.2,0.4-0.6,0.4-0.9c0-0.3-0.1-0.7-0.4-0.9
        C30.8,39.3,30.5,39.2,30.1,39.2z"/>
      <path class="st0" d="M31.1,35.2c0.3-0.2,0.4-0.6,0.4-0.9c0-0.3-0.1-0.7-0.4-0.9c-0.3-0.2-0.6-0.4-0.9-0.4l0,0l0,0H8.3
        c-0.4,0-0.7,0.1-0.9,0.4C7.1,33.6,7,33.9,7,34.3c0,0.3,0.1,0.7,0.4,0.9c0.3,0.2,0.6,0.4,0.9,0.4l0,0l0,0h21.8
        C30.5,35.6,30.8,35.4,31.1,35.2z"/>
      <path class="st0" d="M75.4,36.1l-0.1-0.5c-0.4-1.5-1.9-2.6-3.4-2.6H38.4c-2,0-3.6,1.6-3.6,3.6v21.7c0,2,1.6,3.6,3.6,3.6h4.4l0.1,0.5
        c0.8,2.7,3.3,4.6,6.2,4.6c2.8,0,5.4-1.9,6.2-4.6l0.1-0.5h17.6l0.1,0.5c0.8,2.7,3.4,4.6,6.2,4.6c2.8,0,5.4-1.9,6.2-4.6l0.1-0.5h4.5
        c1.5,0,2.8-1.3,2.8-2.8V48.9c0-1.5-1.3-2.8-2.8-2.8h-0.7L89,45.1c-0.7-1.4-1.5-3.1-2.5-4.7c-0.7-1.2-1.4-2.1-2.1-2.8
        c-0.7-0.8-1.5-1.5-2.8-1.5H75.4z M53,60.6c0,2.2-1.7,3.9-3.9,3.9c-2.2,0-3.9-1.7-3.9-3.9c0-2.2,1.7-3.9,3.9-3.9
        C51.4,56.7,53,58.4,53,60.6L53,60.6z M72.8,59.3H55.5l-0.1-0.5c-0.8-2.8-3.3-4.7-6.2-4.7c-2.8,0-5.4,1.9-6.2,4.7l-0.1,0.5h-4.4
        c-0.5,0-1-0.5-1-1V36.6c0-0.6,0.4-1,1-1l33.4,0c0.5,0,1,0.5,1,1V59.3z M79.4,64.4c-2.2,0-3.9-1.7-3.9-3.9c0-2.2,1.8-3.9,3.9-3.9
        c2.3,0.1,3.9,1.7,3.9,3.9C83.3,62.8,81.6,64.4,79.4,64.4z M90.4,48.7v10.6h-4.7l-0.1-0.5c-0.6-2.8-2.9-4.5-6.2-4.6
        c-1,0-2.1,0.3-3,0.7l-1,0.5v-6.7H90.4z M82.6,39.3c0.5,0.5,1.1,1.4,1.7,2.4c0.6,1,1.2,2.1,1.9,3.5l0.5,1H75.4v-7.5h6.1l0.2,0
        l0.2,0.1C82,38.9,82.3,39,82.6,39.3z"/>
    </symbol>

  </defs>
</svg>


    <div class="container-wrapper">
      <div class="container-site">
        <script>
  window.current_publisher_code = "digg";
</script>

<div class="hello-bar js-hello-bar hidden-xs hidden-sm">
  <div class="container">
      <div class="pull-left">
        <a class="back-link" href="http://digg.com/">
          <i class='fa fa-sm fa-chevron-left back-to-publisher'></i> back to digg.com
</a>      </div>


      <div class="">
        <a class="hello-bar-text js-hello-bar" data-sale-slug="air-bud-wireless-bluetooth-earbuds-3" data-track-click="{&quot;category&quot;:&quot;HelloBar&quot;,&quot;label&quot;:&quot;link&quot;}" impression_list="hello bar" href="/collections/2018-fourth-of-july">
          Save An Additional 15% Off Site Wide W/ Code JULY4TH
          <i class="fa fa-chevron-right"></i>
</a>      </div>

    <a class="referal-link" data-track-click="{&quot;category&quot;:&quot;HelloBar&quot;,&quot;label&quot;:&quot;refer link&quot;}" href="/user/credits">
      Give $10,
      Get $10
</a>  </div>
</div>

<nav id="main-navbar"
  class="navbar navbar-default navbar-fixed-top navbar-master js-navbar-master"
  role="navigation"
  data-navbar>

  <div class="container">
    <div class="navbar-header">
      <button class="navbar-toggle navbar-menu-button pull-left" type="button">
        <span class="sr-only">Toggle navigation</span>
        <span class="icon-bar icon-bar-middle"></span>
        <span class="icon-bar icon-bar-middle"></span>
        <span class="icon-bar icon-bar-middle"></span>
      </button>

      <div class="navbar-toggle mobile-cart-icon mini-cart">
        <mini-cart-button></mini-cart-button>
      </div>

      <div class="navbar-toggle mobile-search-icon js-toggleSearchNav">
        <svg class="svg-icon search-input-icon">
          <use xlink:href="#icon-search"></use>
        </svg>
      </div>

      <div class="navbar-brand-container">
        <a class="navbar-brand" href="/">
            <img class="navbar-logo hidden-xs hidden-sm" alt="Digg" src="https://cdnp2.stackassets.com/6bb1b0c4b5b2c69fbe228a7e8ed974eb3f33579b/store/c955c12e55d585985198f1ace9a068fc5460be420701cce2f5f96f447b30/28cfa6b9164214d3cee54b990b00d4d09781aea6_logo_main.png" />

    <img class="navbar-logo hidden-md hidden-lg" alt="Digg" src="https://cdnp1.stackassets.com/7233e69003b00a8364724db622d71fbae54b3efc/store/f2e980f91ac9866426d222b593e6332923e0dbac41c3f53b6fa4089945fe/8570c0924c5e16dc571c4330dcef195d95089b07_logo_main_mobile.png" />

</a>      </div>
    </div>

    <div class="navbar-collapse">
      <div class="navbar-center">
        <div class="hidden-xs hidden-sm navbar-search">
          <form class="form-inline js-search-form" action="/search" accept-charset="UTF-8" method="get"><input name="utf8" type="hidden" value="&#x2713;" />
            <div class="search-container">
              <input type="text" name="query" id="query" placeholder="Search" class="search-input" required="required" />
              <i class="fa fa-search search-input-icon"></i>
            </div>
</form>        </div>

        <ul class="nav navbar-nav navbar-right nav-account hidden-xs hidden-sm">
          <li class="heart-icon-nav">
            <a class="nav-account-link js-wishlist-nav" href="/user?show=home-tab">
              <svg class="svg-icon">
                <use xlink:href="#icon-heart"></use>
              </svg>
</a>          </li>
          <li class="cart-icon-nav">
            <mini-cart-button></mini-cart-button>
          </li>
            <li>
    <a class="nav-account-link" href="/sign_in?source=signup_page">Login</a>
  </li>

        </ul>
      </div>

      
<ul class="nav navbar-nav navbar-main js-navbar-main nav-4-items">
  
    

      

          <li class="dropdown nav-item nav-item-container js-mobile-dropdown ">
            <a class="mobile-dropdown-toggle nav-item-link js-root-menu-item" role="button" href="#">
              Categories
</a>            <div class="dropdown-menu mega-menu" role="menu">
              <div class="container">
                <ul class="list-unstyled menu-list">
                    
                      <li class="subnav-menu subnav-menu-group dropdown js-mobile-dropdown">
                          <a class="subnav-menu-label js-child-menu-item mobile-dropdown-toggle" href="/collections/online-courses">
                            Online Courses
</a>
                          <ul class="list-unstyled js-nav-filters">
                              
                                  <li class="subnav-menu-items">
                                    <a class="js-third-level-menu-item" href="/collections/online-courses/development">
                                      Development
</a>                                  </li>
                              
                                  <li class="subnav-menu-items">
                                    <a class="js-third-level-menu-item" href="/collections/online-courses/it-security">
                                      IT + Security
</a>                                  </li>
                              
                                  <li class="subnav-menu-items">
                                    <a class="js-third-level-menu-item" href="/collections/online-courses/business">
                                      Business
</a>                                  </li>
                              
                                  <li class="subnav-menu-items">
                                    <a class="js-third-level-menu-item" href="/collections/online-courses/photography">
                                      Photography
</a>                                  </li>
                              
                                  <li class="subnav-menu-items">
                                    <a class="js-third-level-menu-item" href="/collections/online-courses/marketing">
                                      Marketing
</a>                                  </li>
                              
                                  <li class="subnav-menu-items">
                                    <a class="js-third-level-menu-item" href="/collections/online-courses/design">
                                      Design
</a>                                  </li>
                              
                                  <li class="subnav-menu-items">
                                    <a class="js-third-level-menu-item" href="/collections/online-courses/self">
                                      Self
</a>                                  </li>
                          </ul>
                      </li>
                    
                      <li class="subnav-menu subnav-menu-group dropdown js-mobile-dropdown">
                          <a class="subnav-menu-label js-child-menu-item mobile-dropdown-toggle" href="/collections/gear-gadgets">
                            Gear + Gadgets
</a>
                          <ul class="list-unstyled js-nav-filters">
                              
                                  <li class="subnav-menu-items">
                                    <a class="js-third-level-menu-item" href="/collections/gear-gadgets/sound">
                                      Sound
</a>                                  </li>
                              
                                  <li class="subnav-menu-items">
                                    <a class="js-third-level-menu-item" href="/collections/gear-gadgets/power">
                                      Power
</a>                                  </li>
                              
                                  <li class="subnav-menu-items">
                                    <a class="js-third-level-menu-item" href="/collections/gear-gadgets/connected-devices">
                                      Connected Devices
</a>                                  </li>
                              
                                  <li class="subnav-menu-items">
                                    <a class="js-third-level-menu-item" href="/collections/gear-gadgets/diy">
                                      DIY
</a>                                  </li>
                              
                                  <li class="subnav-menu-items">
                                    <a class="js-third-level-menu-item" href="/collections/gear-gadgets/mobile">
                                      Mobile
</a>                                  </li>
                              
                                  <li class="subnav-menu-items">
                                    <a class="js-third-level-menu-item" href="/collections/gear-gadgets/photography">
                                      Photography
</a>                                  </li>
                              
                                  <li class="subnav-menu-items">
                                    <a class="js-third-level-menu-item" href="/collections/gear-gadgets/gaming-toys">
                                      Gaming + Toys
</a>                                  </li>
                              
                                  <li class="subnav-menu-items">
                                    <a class="js-third-level-menu-item" href="/collections/gear-gadgets/auto">
                                      Auto
</a>                                  </li>
                          </ul>
                      </li>
                    
                      <li class="subnav-menu subnav-menu-group dropdown js-mobile-dropdown">
                          <a class="subnav-menu-label js-child-menu-item mobile-dropdown-toggle" href="/collections/lifestyle">
                            Lifestyle
</a>
                          <ul class="list-unstyled js-nav-filters">
                              
                                  <li class="subnav-menu-items">
                                    <a class="js-third-level-menu-item" href="/collections/lifestyle-vices">
                                      Vices
</a>                                  </li>
                              
                                  <li class="subnav-menu-items">
                                    <a class="js-third-level-menu-item" href="/collections/lifestyle/accessories">
                                      Accessories
</a>                                  </li>
                              
                                  <li class="subnav-menu-items">
                                    <a class="js-third-level-menu-item" href="/collections/lifestyle/everyday-carry">
                                      Everyday Carry
</a>                                  </li>
                              
                                  <li class="subnav-menu-items">
                                    <a class="js-third-level-menu-item" href="/collections/lifestyle/home">
                                      Home
</a>                                  </li>
                              
                                  <li class="subnav-menu-items">
                                    <a class="js-third-level-menu-item" href="/collections/watches">
                                      Watches
</a>                                  </li>
                              
                                  <li class="subnav-menu-items">
                                    <a class="js-third-level-menu-item" href="/collections/lifestyle/travel">
                                      Travel
</a>                                  </li>
                              
                                  <li class="subnav-menu-items">
                                    <a class="js-third-level-menu-item" href="/collections/lifestyle/fitness">
                                      Fitness
</a>                                  </li>
                          </ul>
                      </li>
                    
                      <li class="subnav-menu subnav-menu-group dropdown js-mobile-dropdown">
                          <a class="subnav-menu-label js-child-menu-item mobile-dropdown-toggle" href="/collections/software">
                            Apps + Software
</a>
                          <ul class="list-unstyled js-nav-filters">
                              
                                  <li class="subnav-menu-items">
                                    <a class="js-third-level-menu-item" href="/collections/software/security">
                                      Security
</a>                                  </li>
                              
                                  <li class="subnav-menu-items">
                                    <a class="js-third-level-menu-item" href="/collections/software/utilities">
                                      Utilities
</a>                                  </li>
                              
                                  <li class="subnav-menu-items">
                                    <a class="js-third-level-menu-item" href="/collections/software/productivity">
                                      Productivity
</a>                                  </li>
                              
                                  <li class="subnav-menu-items">
                                    <a class="js-third-level-menu-item" href="/collections/software/backup-storage">
                                      Backup + Storage
</a>                                  </li>
                              
                                  <li class="subnav-menu-items">
                                    <a class="js-third-level-menu-item" href="/collections/software/entertainment">
                                      Entertainment
</a>                                  </li>
                              
                                  <li class="subnav-menu-items">
                                    <a class="js-third-level-menu-item" href="/collections/software/design">
                                      Design
</a>                                  </li>
                          </ul>
                      </li>
                </ul>
              </div>
            </div>
          </li>
      

          <li class="dropdown nav-item nav-item-container js-mobile-dropdown ">
            <a class="mobile-dropdown-toggle nav-item-link js-root-menu-item" role="button" href="#">
              Collections
</a>            <div class="dropdown-menu mega-menu" role="menu">
              <div class="container">
                <ul class="list-unstyled menu-list">
                    
                      <li class="subnav-menu subnav-menu-group dropdown js-mobile-dropdown">
                          <span class="subnav-menu-label mobile-dropdown-toggle">
                            Interests
                          </span>

                          <ul class="list-unstyled js-nav-filters">
                              
                                  <li class="subnav-menu-items">
                                    <a class="js-third-level-menu-item" href="/collections/shop-by-interest-apple-mac">
                                      Apple / Mac
</a>                                  </li>
                              
                                  <li class="subnav-menu-items">
                                    <a class="js-third-level-menu-item" href="/collections/shop-by-interest-science">
                                      Science
</a>                                  </li>
                              
                                  <li class="subnav-menu-items">
                                    <a class="js-third-level-menu-item" href="/collections/shop-by-specialization-developer">
                                      Developer
</a>                                  </li>
                              
                                  <li class="subnav-menu-items">
                                    <a class="js-third-level-menu-item" href="/collections/shop-by-interest-android">
                                      Android
</a>                                  </li>
                              
                                  <li class="subnav-menu-items">
                                    <a class="js-third-level-menu-item" href="/collections/gamer">
                                      Gamer
</a>                                  </li>
                              
                                  <li class="subnav-menu-items">
                                    <a class="js-third-level-menu-item" href="/collections/shop-by-specialization-designer">
                                      Designer
</a>                                  </li>
                              
                                  <li class="subnav-menu-items">
                                    <a class="js-third-level-menu-item" href="/collections/hacking">
                                      Hacking
</a>                                  </li>
                          </ul>
                      </li>
                    
                      <li class="subnav-menu subnav-menu-group dropdown js-mobile-dropdown">
                          <span class="subnav-menu-label mobile-dropdown-toggle">
                            Featured
                          </span>

                          <ul class="list-unstyled js-nav-filters">
                              
                                  <li class="subnav-menu-items">
                                    <a class="js-third-level-menu-item" href="/best-sellers">
                                      Best Sellers
</a>                                  </li>
                              
                              
                                  <li class="subnav-menu-items">
                                    <a class="js-third-level-menu-item" href="/collections/lifetime-deals">
                                      Lifetime Subscriptions
</a>                                  </li>
                              
                                  <li class="subnav-menu-items">
                                    <a class="js-third-level-menu-item" href="/collections/pay-what-you-want">
                                      Pay What You Want
</a>                                  </li>
                              
                                  <li class="subnav-menu-items">
                                    <a class="js-third-level-menu-item" href="/collections/citizengoods-exclusives">
                                      Exclusive Deals
</a>                                  </li>
                              
                                  <li class="subnav-menu-items">
                                    <a class="js-third-level-menu-item" href="/collections/international">
                                      International
</a>                                  </li>
                          </ul>
                      </li>
                    
                      <li class="subnav-menu subnav-menu-group dropdown js-mobile-dropdown">
                          <span class="subnav-menu-label mobile-dropdown-toggle">
                            Staff Picks
                          </span>

                          <ul class="list-unstyled js-nav-filters">
                              
                                  <li class="subnav-menu-items">
                                    <a class="js-third-level-menu-item" href="/collections/tag-cyber-security">
                                      VPNs &amp; Cyber Security
</a>                                  </li>
                              
                                  <li class="subnav-menu-items">
                                    <a class="js-third-level-menu-item" href="/collections/drones">
                                      Drones
</a>                                  </li>
                              
                                  <li class="subnav-menu-items">
                                    <a class="js-third-level-menu-item" href="/collections/under-20">
                                      Under $20
</a>                                  </li>
                              
                                  <li class="subnav-menu-items">
                                    <a class="js-third-level-menu-item" href="/collections/citizengoods-subscriptions">
                                      Subscriptions
</a>                                  </li>
                              
                          </ul>
                      </li>
                </ul>
              </div>
            </div>
          </li>
      

          <li class="nav-item ">
            <a class="nav-item-link" href="/free">Free</a>
          </li>
      

          <li class="nav-item ">
            <a class="nav-item-link" href="/giveaways">Giveaways</a>
          </li>

  <li class="nav-username-placeholder hidden-sm hidden-xs">
      Login
  </li>

  <li class="nav-item visible-xs visible-sm">
  <a class="nav-item-link" href="/user?show=home-tab">Wishlist</a>
</li>
  <li class="nav-item visible-xs visible-sm">
    <a class="nav-item-link" href="/sign_in?source=signup_page">Login</a>
  </li>

</ul>

    </div>
  </div>

  <div id="search-dropdown-bar"
    class="hidden-md hidden-lg navbar-search-mobile container js-search-dropdown-bar">
    <form class="form-inline js-search-form" action="/search" accept-charset="UTF-8" method="get"><input name="utf8" type="hidden" value="&#x2713;" />
      <input type="text" name="query" id="mobile-search-box" placeholder="Search" class="form-control search-input js-mobile-search-box" />
</form>  </div>

  
</nav>

<div id="main-navbar-phantom" class="js-main-navbar-phantom"></div>
<div class="mobile-nav-overlay"></div>


<mini-cart></mini-cart>

        

        <div class="site-contents">
          <div class="loyalty-callout loyalty-callout--bar loyalty-callout--bundle ">
  <div class="loyalty-callout__content">
    <div class="loyalty-callout__icon">
      <?xml version="1.0" encoding="utf-8"?>
<!-- Generator: Adobe Illustrator 20.1.0, SVG Export Plug-In . SVG Version: 6.00 Build 0)  -->
<svg version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px"
	 viewBox="0 0 35 34" style="enable-background:new 0 0 35 34;" xml:space="preserve">
<style type="text/css">
	.st0{fill:currentColor;}
</style>
<g>
	<path class="st0" d="M28.5,2.5h-7.6c-1.2,0-2.7,0.6-3.5,1.4L2.7,18.5C2.3,19,2,19.6,2,20.3c0,0.7,0.3,1.3,0.7,1.8l8.6,8.6
		c0.5,0.5,1.1,0.7,1.8,0.7v0c0.7,0,1.3-0.3,1.8-0.7l14.6-14.6c0.8-0.8,1.4-2.3,1.4-3.5V5C31,3.6,29.9,2.5,28.5,2.5z M29.3,12.7
		c0,0.7-0.5,1.8-1,2.3L13.8,29.6c-0.2,0.2-0.4,0.2-0.6,0.2c-0.2,0-0.4-0.1-0.6-0.2l-8.6-8.6c-0.2-0.2-0.2-0.4-0.2-0.6
		s0.1-0.4,0.2-0.6L18.5,5.2c0.5-0.5,1.6-1,2.3-1h0h7.6c0.5,0,0.8,0.4,0.8,0.8V12.7z"/>
	<path class="st0" d="M25.1,5.9c-1.4,0-2.5,1.1-2.5,2.5c0,1.4,1.1,2.5,2.5,2.5s2.5-1.1,2.5-2.5C27.6,7,26.5,5.9,25.1,5.9z M25.1,9.3
		c-0.5,0-0.8-0.4-0.8-0.8c0-0.5,0.4-0.8,0.8-0.8c0.5,0,0.8,0.4,0.8,0.8C25.9,8.9,25.5,9.3,25.1,9.3z"/>
</g>
</svg>

    </div>
    <span class="loyalty-callout__text">
      Get $1 credit for every $25 spent!
    </span>
  </div>
</div>



<div id="sc-hero-unit" class="hero-unit-bundle ">
  <div class="container">
    <div class="row">
      <header class="col-xs-12 header">
        <div class="row">
         <article class="col-xs-12">
           <h1>The Python Power Coder BONUS Bundle</h1>
           <h4 class="hidden-xs hidden-sm">3 New, In-Depth Courses Bring This Python Bundle to 70 Resume-Enhancing Hours of Content</h4>
         </article>
        </div>
      </header>
    </div>

    <div class="row">
      <article class="col-xs-12 col-md-7 col-lg-6">
        <div class="row">
          <div class="sc-hero-unit-clock col-xs-12 visible-xs visible-sm">
            <i class="icon-clock"></i>
            Ending In: <abbr class="js-interval" data-use-interval="true" data-starts-at="2016-09-29T04:00:00Z" data-ends-at="2021-09-29T06:59:00Z"></abbr>
          </div>
          <div class="sc-hero-unit-buy-button col-md-7 col-xs-12">
            <div class="row">
              <ng-form class="buy-form form-horizontal js-sc-purchase-form" data-type="Bundle" data-price="44.0" data-name="The Python Power Coder BONUS Bundle" data-ids="[5556]" role="form" ng-controller="AddToCartCtrl">

  <input type="hidden" name="sale_id" id="sale_id" value="5556" data-sale-slug="the-python-power-coder-bonus-bundle" />


  <div class="col-md-8 col-xs-12 col-lg-9 ">
    <add-to-cart-button class="hidden-xs hidden-sm btn btn-lg btn-block btn-success js-purchase-submit form-control additem" ng-click="addItem()" ng-disabled="addingToCart" data-button-type="buy_now">
      Add to Cart - $44
</add-to-cart-button>    <add-to-cart-button class="visible-xs visible-sm btn btn-lg btn-success js-sc-sale-form-submit-mobile form-control" ng-click="addItem()" ng-disabled="addingToCart" data-button-type="buy_now">
      <span>Add to Cart - $44</span>
</add-to-cart-button>  </div>

    <div class="hidden-md hidden-lg select-mobile">
      <select name="quantity" id="quantity" class="form-control js-quantity" data-price="4400" ng-model="quantity"><option value="1">1</option>
<option value="2">2</option>
<option value="3">3</option>
<option value="4">4</option>
<option value="5">5</option></select>
    </div>

    <div class="select-right hidden-xs hidden-sm col-md-4 col-lg-3">
      <select name="quantity" id="quantity" class="form-control js-quantity" data-price="4400" ng-model="quantity"><option value="1">1</option>
<option value="2">2</option>
<option value="3">3</option>
<option value="4">4</option>
<option value="5">5</option></select>
    </div>
</ng-form>
<div class="buy-now-fixed js-sc-sale-buy-now-fixed">
  <div class="js-no-variant" data-type="Bundle" data-toggle="#sc-purchase-form"><add-to-cart-button class="btn btn-success btn-lg btn-block js-no-variant-text" data-button-type="buy_now">Add to Cart ($44)</add-to-cart-button></div>
</div>

            </div>
          </div>
            <div class="col-md-5 col-xs-12">
              <div class="sc-hero-unit-promotion">
                <div class="retail-price">$1,075</div>
                <div class="percent-off">
                  95% off
</div>              </div>
            </div>
        </div>
        <div class="row">
          <div class="col-sm-12">
            <div class="sc-hero-unit-clock hidden-xs hidden-sm pull-left">
              <i class="icon-clock"></i>
              Ending In: <abbr class="js-interval" data-use-interval="true" data-starts-at="2016-09-29T04:00:00Z" data-ends-at="2021-09-29T06:59:00Z"></abbr>
            </div>
            <a class="sc-favorite-icon js-favorite js-favorite-track primary-color " id="favorite-bundle" data-sale-name="The Python Power Coder BONUS Bundle" data-sale-id="5556" data-category="Sale" href="">
  <i class="fa fa-heart" aria-hidden="true"></i>
  <i class="fa fa-heart-o" aria-hidden="true"></i>

  <span class="text-capitalize">
      wishlist
  </span>
</a>
              <div class="bundle-star-rating">
                <div class="bundle-star-rating-content">
                    <fieldset class="rating">
      <input type="radio" checked=&quot;checked&quot;/>
      <label class="full"></label>
      <input type="radio" checked=&quot;checked&quot;/>
      <label class="half"></label>
      <input type="radio" checked=&quot;checked&quot;/>
      <label class="full"></label>
      <input type="radio" checked=&quot;checked&quot;/>
      <label class="half"></label>
      <input type="radio" checked=&quot;checked&quot;/>
      <label class="full"></label>
      <input type="radio" checked=&quot;checked&quot;/>
      <label class="half"></label>
      <input type="radio" checked=&quot;checked&quot;/>
      <label class="full"></label>
      <input type="radio" checked=&quot;checked&quot;/>
      <label class="half"></label>
      <input type="radio" checked=&quot;checked&quot;/>
      <label class="full"></label>
      <input type="radio" checked=&quot;checked&quot;/>
      <label class="half"></label>
  </fieldset>
  <span class="voters">(377)</span>

                </div>
              </div>
          </div>
        </div>
        <div class="row">
          <div class="col-sm-12">
            
<div class="notification-subscription" data-notification-subscription="true" data-tracking-attributes="{&quot;subscription_sale_id&quot;:5556}">
  <button class="notification-subscription__cta primary-color">
    <i class="fa fa-bell-o"></i>
    <span class="subscribe-text">Stay up-to-date on exclusive new deals!</span>
  </button>
</div>
          </div>
        </div>
      </article>
    </div>
  </div>
</div>

<div class="container sc-bundle-page" data-sale="{&quot;id&quot;:5556,&quot;name&quot;:&quot;The Python Power Coder BONUS Bundle&quot;,&quot;title&quot;:&quot;3 New, In-Depth Courses Bring This Python Bundle to 70 Resume-Enhancing Hours of Content&quot;,&quot;price_in_cents&quot;:4400,&quot;categories&quot;:[{&quot;name&quot;:&quot;Programming Languages&quot;},{&quot;name&quot;:&quot;Web Development&quot;}]}" data-track-detail="{&quot;list&quot;:&quot;bundle page&quot;}" data-sales-show-page="true" data-page-bundlePage="true" id="sc-bundle-page">
  <section>
    <header>
      <div class="bundle-page-heading">
        <h4>What's Included</h4>
      </div>
    </header>
    <section class="row">
      <div class="products-grid">
        <div class="products-grid-list">
    <div class="pagination-table-row products-grid-product anchor-link"
      data-toggle=".product-detail-header"
      data-toggle-view-all="#product-details-10852">

      <div class="products-grid-logo">
        
          <img class="img-responsive" src="https://cdnp3.stackassets.com/e5a3fdeb9b9125601f7dbf8c593b945576ff83ad/store/opt/204/153/d85ea013fcaef767d1af13a7bdc04b61aa66b05db4704432feb5303e16ce/8afa1643b907c743b2d48b173ad2c4b4a2a2f0cb_main_hero_image.jpg" alt="8afa1643b907c743b2d48b173ad2c4b4a2a2f0cb main hero image" />

      </div>
      <div class="products-grid-details ">
        <span class="products-grid-name">The Developers&#39; Guide to Python 3 Programming</span>
          <div class="products-grid-price">$49 Value</div>
      </div>
    </div>
    <div class="pagination-table-row products-grid-product anchor-link"
      data-toggle=".product-detail-header"
      data-toggle-view-all="#product-details-11895">

      <div class="products-grid-logo">
        
          <img class="img-responsive" src="https://cdnp0.stackassets.com/062130caf8043f232b44dc7ef6aea32ef3408035/store/opt/204/153/0d90fbdad55ca26778ea2d42a6fe1dc323768f0539164205cde973bdf807/42ba262d6c92194033d340f43037d71f3c2eebc9_main_hero_image.jpg" alt="42ba262d6c92194033d340f43037d71f3c2eebc9 main hero image" />

      </div>
      <div class="products-grid-details ">
        <span class="products-grid-name">Step by Step: Build a Data Analysis Program</span>
          <div class="products-grid-price">$95 Value</div>
      </div>
    </div>
    <div class="pagination-table-row products-grid-product anchor-link"
      data-toggle=".product-detail-header"
      data-toggle-view-all="#product-details-11896">

      <div class="products-grid-logo">
        
          <img class="img-responsive" src="https://cdnp2.stackassets.com/63fbc7faeec9529f4364bc70bc7dea5edbc64155/store/opt/204/153/b41a6cf1ea40af0f501b91bbc63d00b4d52b8170c1260d1b9961a9d2250b/2632b0893cbf03d0ed12765b471524549be355a9_main_hero_image.jpg" alt="2632b0893cbf03d0ed12765b471524549be355a9 main hero image" />

      </div>
      <div class="products-grid-details ">
        <span class="products-grid-name">The Python Mega Course: Build 10 Real World Applications</span>
          <div class="products-grid-price">$195 Value</div>
      </div>
    </div>
    <div class="pagination-table-row products-grid-product anchor-link"
      data-toggle=".product-detail-header"
      data-toggle-view-all="#product-details-10885">

      <div class="products-grid-logo">
        
          <img class="img-responsive" src="https://cdnp3.stackassets.com/50fc098e847df296d3239a9094673ca0f19a3c63/store/opt/204/153/5e110d7469fd99f19eda2280d1b6c23d66a1bb12d61b6b39214efe93435d/ae89a62c85e8cdec65bf6fec00bbc2b576f776ca_main_hero_image.jpg" alt="Ae89a62c85e8cdec65bf6fec00bbc2b576f776ca main hero image" />

      </div>
      <div class="products-grid-details ">
        <span class="products-grid-name">The Complete Computer Vision Course with Python</span>
          <div class="products-grid-price">$149 Value</div>
      </div>
    </div>
    <div class="pagination-table-row products-grid-product anchor-link"
      data-toggle=".product-detail-header"
      data-toggle-view-all="#product-details-10376">

      <div class="products-grid-logo">
        
          <img class="img-responsive" src="https://cdnp2.stackassets.com/57bb6dda23713c1ae9e5a3d459b86c86a29d645b/store/opt/204/153/9b9ff37ae559fb10f925ba94ebd897196e734818985958455cb2dc32dd23/401ede524cd760bf1eb8f07f59d9a87693167343_main_hero_image.jpg" alt="401ede524cd760bf1eb8f07f59d9a87693167343 main hero image" />

      </div>
      <div class="products-grid-details ">
        <span class="products-grid-name">Learn Python 3 from Scratch</span>
          <div class="products-grid-price">$99 Value</div>
      </div>
    </div>
    <div class="pagination-table-row products-grid-product anchor-link"
      data-toggle=".product-detail-header"
      data-toggle-view-all="#product-details-10435">

      <div class="products-grid-logo">
        
          <img class="img-responsive" src="https://cdnp2.stackassets.com/8df08a0aa4e9dd769109f35c45b07d279d4638b6/store/opt/204/153/6bbff90c1b0ac03fc2dd9908fbc434c2ab9b81ea8c5cda03c7556acf987d/f29add08113120af3fabbff3ad2acab29896154d_main_hero_image.jpg" alt="F29add08113120af3fabbff3ad2acab29896154d main hero image" />

      </div>
      <div class="products-grid-details ">
        <span class="products-grid-name">Python Tutorial: Python Network Programming - Build 7 Apps</span>
          <div class="products-grid-price">$299 Value</div>
      </div>
    </div>
    <div class="pagination-table-row products-grid-product anchor-link"
      data-toggle=".product-detail-header"
      data-toggle-view-all="#product-details-11186">

      <div class="products-grid-logo">
        
          <img class="img-responsive" src="https://cdnp0.stackassets.com/dd5a7397b51cd6c8c3ab29965c0fe5c5d63d9e4d/store/opt/204/153/8302fe3354386903a3327a7258173a89b4f527674633a9663ecc8fa62a8b/69bcf5a6885371a16f8867dff5ebf33489e32499_main_hero_image.jpg" alt="69bcf5a6885371a16f8867dff5ebf33489e32499 main hero image" />

      </div>
      <div class="products-grid-details ">
        <span class="products-grid-name">Python Web Programming</span>
          <div class="products-grid-price">$100 Value</div>
      </div>
    </div>
    <div class="pagination-table-row products-grid-product anchor-link"
      data-toggle=".product-detail-header"
      data-toggle-view-all="#product-details-11187">

      <div class="products-grid-logo">
        
          <img class="img-responsive" src="https://cdnp1.stackassets.com/a206596a5b73c4e2ecdf4b6bec4c3486acb51b5c/store/opt/204/153/70e6c323c0f1dcf8f20da1b181ebb0e0ffc0bd71ecad25567331d5c4699e/80ea614671f169144e39b550e3153efd4d92d502_main_hero_image.jpg" alt="80ea614671f169144e39b550e3153efd4d92d502 main hero image" />

      </div>
      <div class="products-grid-details ">
        <span class="products-grid-name">Taming Big Data with Apache Spark and Python</span>
          <div class="products-grid-price">$89 Value</div>
      </div>
    </div>
</div>

      </div>
    </section>
  </section>

  <hr class="hidden-xs hidden-sm">

  <section class="row">
    <div
  class="bundle-summary-container js-pagination-container"
  data-prev=".pagination-prev"
  data-next=".pagination-next"
  data-counter=".pagination-counter"
  data-table-row=".pagination-table-row"
>
  <div class="product-detail-header">
    <div class="container">
      <div class="row">
        <div class="col-xs-6 col-md-8">
          <h4>Product Details</h4>
        </div>
        <div class="col-xs-6 col-md-4">
          <h4 class="pull-right navbar-pagination">
            <i class="fa fa-chevron-left pagination-prev"></i><span class="pagination-counter">1</span> <em>of</em> 8<i class="fa fa-chevron-right pagination-next"></i>
          </h4>
        </div>
      </div>
    </div>
  </div>
  <div class="product-detail-body">
    <div class="container">
      <div class="row">
        <div class="col-xs-12">
            <div id="product-details-10852" class="js-product-details row pagination-details active">
              <div class="col-md-6">
                <div id="sc-product-image-carousel10852" class="sc-product-image-carousel carousel slide" data-ride="carousel" data-toughness="0.25" data-interval=false>
  
      <picture><source media="(max-width: 479px)" srcset="https://cdnp3.stackassets.com/0fec299d71c637c9c9e4254e366877b1e858596b/store/opt/450/225/b41b6e0eecc029aa3f6e3cacd09eda56a583857e8e7ecffd84ed9bed1c85/15d35c7234df8918dc62f828cb13a20adf0f16c2_main_hero_image.jpg" /><source media="(min-width: 480px) and (max-width: 991px)" srcset="https://cdnp3.stackassets.com/50e8170282e5918bc2f851bef848610c18cdf8bc/store/opt/b41b6e0eecc029aa3f6e3cacd09eda56a583857e8e7ecffd84ed9bed1c85/15d35c7234df8918dc62f828cb13a20adf0f16c2_main_hero_image.jpg" /><source media="(min-width: 992px) and (max-width: 1199px)" srcset="https://cdnp3.stackassets.com/81a8f19cb54f9ad02d76faf5d3f26cbbd527974f/store/opt/489/244/b41b6e0eecc029aa3f6e3cacd09eda56a583857e8e7ecffd84ed9bed1c85/15d35c7234df8918dc62f828cb13a20adf0f16c2_main_hero_image.jpg" /><img class="img-responsive" src="https://cdnp3.stackassets.com/4e6dd94605a6ea645fb2ab876bc3746621f5e319/store/opt/596/298/b41b6e0eecc029aa3f6e3cacd09eda56a583857e8e7ecffd84ed9bed1c85/15d35c7234df8918dc62f828cb13a20adf0f16c2_main_hero_image.jpg" alt="15d35c7234df8918dc62f828cb13a20adf0f16c2 main hero image" /></picture>
</div>


                    <div class="bubble-bundle-page-product-details text-center">
                      <div class="bubble">
  <div class="title">Access</div>
  <div class="value">Lifetime</div>
</div>

                      <div class="bubble">
  <div class="title">Content</div>
  <div class="value">4 hours</div>
</div>

                      <div class="bubble">
  <div class="title">Lessons</div>
  <div class="value">22</div>
</div>

                    </div>
              </div>
              <div class="col-md-6 course">
                <h3><strong>The Developers&#39; Guide to Python 3 Programming</strong></h3>
                <h4>
                  Want to Code? Python 3 is the Perfect Place to Start
                </h4>

                <p>
                  By <a class="brand-primary anchor-link instructor-link" href="#product_10852-instructor">Eduonix Technologies</a>
                    | in <a class="brand-primary" href="/collections/online-courses">Online Courses</a>
                </p>
                  <div class="bundle-page-product-details">
  
  <ul class="nav nav-tabs " role="tablist">
      <li class="col-xs-4 active primary-border-bottom-active">
        <a data-toggle="tab"
          id="product_10852-description"
          role="tab"
          class="text-capitalize js-product-detail"
          href="#product_10852-description-content">
          Description
        </a>
</li>      <li class="col-xs-4  primary-border-bottom-active">
        <a data-toggle="tab"
          id="product_10852-instructor"
          role="tab"
          class="text-capitalize js-product-detail"
          href="#product_10852-instructor-content">
          Instructor
        </a>
</li>      <li class="col-xs-4  primary-border-bottom-active">
        <a data-toggle="tab"
          id="product_10852-specs"
          role="tab"
          class="text-capitalize js-product-detail"
          href="#product_10852-specs-content">
          Specs
        </a>
</li>  </ul>

  <div class="tab-content">
    <div class="tab-pane active fade in" id="product_10852-description-content" role="tabpanel">
      Python is an excellent first programming language because of its simple syntax, coding principles, and easy readability. It is a simple, yet powerful programming language that allows developers to build complex websites without complex code. First time coders will find Python to be a great jumping off point, and can use the skills they learn in this course to take on greater coding challenges.
<br><br>
<ul><li>Access 22 lectures & 4 hours of content 24/7
<li>Learn basic Python concepts like functions, conditions, loops & objects
<li>Discover object-oriented programming principles
<li>Understand classes, package & modules, exceptions & more
<li>Code your very own program w/ Python</ul>
    </div>
    <div class="tab-pane  fade in" id="product_10852-instructor-content" role="tabpanel">
      Eduonix creates and distributes high-quality technology training content. Their team of industry professionals has been training manpower for more than a decade. They aim to teach technology the way it is used in the industry and professional world. They have a professional team of trainers for technologies ranging from Mobility, Web and Enterprise, and Database and Server Administration.
<br><br>
If you have any questions, feel free to contact Eduonix at info@eduonix.com.
    </div>
    <div class="tab-pane  fade in" id="product_10852-specs-content" role="tabpanel">
      <p>Details & Requirements</p>

<ul><li>Length of time users can access this course: lifetime
<li>Access options: web streaming, mobile streaming
<li>Certification of completion not included
<li>Redemption deadline: redeem your code within 30 days of purchase
<li>Experience level required: beginner</ul>

<p>Compatibility</p><ul><li>Internet required</ul>
    </div>
  </div>

</div>

  <div class="course-outline inactive">
    <h4 class="title">Course Outline <i class="fa sc-display-outline pull-right"></i></h4>

      <ul>
<li>Introduction to Python

<ul>
<li>Introduction (6:07)</li>
<li>Intro to Python (12:28)</li>
<li>Types and Functions Part A (10:44)</li>
<li>Types and Functions Part B (12:22)</li>
</ul></li>
<li>Loops and Conditionals

<ul>
<li>Conditionals Part A (12:06)</li>
<li>Conditionals Part B (11:40)</li>
<li>Loops Part A (10:55)</li>
<li>Loops Part B (11:36)</li>
</ul></li>
<li>Object oriented programming in Python

<ul>
<li>Objects (13:21)</li>
<li>Classes</li>
<li>Advanced OOP Part A (9:08)</li>
<li>Advanced OOP Part B (12:41)</li>
<li>Package and Modules Part A (10:59)</li>
<li>Package and Modules Part B (12:24)</li>
</ul></li>
<li>Other Python Features

<ul>
<li>Working with Files Part A (12:18)</li>
<li>Working with Files Part B (9:46)</li>
<li>Exceptions Part A (11:16)</li>
<li>Exceptions Part B (10:13)</li>
<li>Standard Library and Applications (17:56)</li>
</ul></li>
<li>Final Project

<ul>
<li>Final Project Part A (18:44)</li>
<li>Final Project Part B (20:29)</li>
</ul></li>
</ul>

    <p class="text-center">
      <a class="open-all" data-target=".course-outline" href>View Full Curriculum</a>
    </p>
  </div>

              </div>
            </div>
            <hr class="product-divider">
            <div id="product-details-11895" class="js-product-details row pagination-details">
              <div class="col-md-6">
                <div id="sc-product-image-carousel11895" class="sc-product-image-carousel carousel slide" data-ride="carousel" data-toughness="0.25" data-interval=false>
  
      <picture><source media="(max-width: 479px)" srcset="https://cdnp3.stackassets.com/c54c7f9cefdf9c38aac6ce39b84f96ac59fb5e92/store/opt/450/225/58be047314c354bc0b2bd925b58e873c4d0b0f9a7ebc5ea2eff2ec3d6242/27dec723e2238e11de6db0dfa8ad9daaf62bac50_main_hero_image.jpg" /><source media="(min-width: 480px) and (max-width: 991px)" srcset="https://cdnp3.stackassets.com/e328e0824613622f05ccb27054d74d52396f64de/store/opt/58be047314c354bc0b2bd925b58e873c4d0b0f9a7ebc5ea2eff2ec3d6242/27dec723e2238e11de6db0dfa8ad9daaf62bac50_main_hero_image.jpg" /><source media="(min-width: 992px) and (max-width: 1199px)" srcset="https://cdnp3.stackassets.com/094ea4f0482dc39cef249decb0e259a94b7fd4be/store/opt/489/244/58be047314c354bc0b2bd925b58e873c4d0b0f9a7ebc5ea2eff2ec3d6242/27dec723e2238e11de6db0dfa8ad9daaf62bac50_main_hero_image.jpg" /><img class="img-responsive" src="https://cdnp3.stackassets.com/42e3d5100c4c83162def7a690cf51acda1631b64/store/opt/596/298/58be047314c354bc0b2bd925b58e873c4d0b0f9a7ebc5ea2eff2ec3d6242/27dec723e2238e11de6db0dfa8ad9daaf62bac50_main_hero_image.jpg" alt="27dec723e2238e11de6db0dfa8ad9daaf62bac50 main hero image" /></picture>
</div>


                    <div class="bubble-bundle-page-product-details text-center">
                      <div class="bubble">
  <div class="title">Access</div>
  <div class="value">Lifetime</div>
</div>

                      <div class="bubble">
  <div class="title">Content</div>
  <div class="value">5.5 hours</div>
</div>

                      <div class="bubble">
  <div class="title">Lessons</div>
  <div class="value">70</div>
</div>

                    </div>
              </div>
              <div class="col-md-6 course">
                <h3><strong>Step by Step: Build a Data Analysis Program</strong></h3>
                <h4>
                  Learn How to Process, Analyze, &amp; Visualize Data Using Python
                </h4>

                <p>
                  By <a class="brand-primary anchor-link instructor-link" href="#product_11895-instructor">Ardit Sulce</a>
                    | in <a class="brand-primary" href="/collections/online-courses">Online Courses</a>
                </p>
                  <div class="bundle-page-product-details">
  
  <ul class="nav nav-tabs " role="tablist">
      <li class="col-xs-4 active primary-border-bottom-active">
        <a data-toggle="tab"
          id="product_11895-description"
          role="tab"
          class="text-capitalize js-product-detail"
          href="#product_11895-description-content">
          Description
        </a>
</li>      <li class="col-xs-4  primary-border-bottom-active">
        <a data-toggle="tab"
          id="product_11895-instructor"
          role="tab"
          class="text-capitalize js-product-detail"
          href="#product_11895-instructor-content">
          Instructor
        </a>
</li>      <li class="col-xs-4  primary-border-bottom-active">
        <a data-toggle="tab"
          id="product_11895-specs"
          role="tab"
          class="text-capitalize js-product-detail"
          href="#product_11895-specs-content">
          Specs
        </a>
</li>  </ul>

  <div class="tab-content">
    <div class="tab-pane active fade in" id="product_11895-description-content" role="tabpanel">
      The world is more data-driven than ever, and Python offers solutions for handling, analyzing, and visualizing large amounts of data effectively. Through this course, you'll learn the valuable data analysis functions of Python that can help separate you from your peers, and make a positive impact in your career.
<br><br>
<ul><li>Access 70 lectures & 5.5 hours of content 24/7
<li>Use real world examples of Python data analysis & visualization
<li>Download, extract, clean, manipulate, analyze, aggregate, & visualize data using only Python
<li>Write your own Python scripts from scratch
<li>Learn various Python libraries, like ftplib, os, glob, pandas, numpy, patoolib, & more</ul>
    </div>
    <div class="tab-pane  fade in" id="product_11895-instructor-content" role="tabpanel">
      Ardit Sulce received his master's degree in Geospatial Technologies from the Institute of Geoinformatics at University of Muenster, Germany. He also holds a Bachelor's degree in Geodetic Engineering.
<br><br>
Ardit offers his expertise in Python development on Upwork where he has worked with companies such as the Swiss in-Terra, Center for Conservation Geography, and Rapid Intelligence. He is the founder of PythonHow where he authors written tutorials about the Python programming language.
    </div>
    <div class="tab-pane  fade in" id="product_11895-specs-content" role="tabpanel">
      <p>Details & Requirements</p><ul><li>Length of time users can access this course: lifetime
<li>Access options: web streaming
<li>Certification of completion  not included
<li>Redemption deadline: redeem your code within 30 days of purchase
<li>Experience level required: all levels</ul><p>Compatibility<br></p><ul><li>Internet required</ul>
    </div>
  </div>

</div>

  <div class="course-outline inactive">
    <h4 class="title">Course Outline <i class="fa sc-display-outline pull-right"></i></h4>

      <ul>
<li>Getting Started

<ul>
<li>Course Introduction (4:21)</li>
<li>An Example of Using Python for Data Analysis And Visualization (8:03)</li>
<li>Installing Python and Python Libraries (7:54)</li>
<li>Python Editors: Spyder and iPython (3:21)</li>
<li>Installing Python and its Libraries (8:24)</li>
</ul></li>
<li>Python Basics

<ul>
<li>Section Intro</li>
<li>Variables (2:47)</li>
<li>Strings and Numbers (4:25)</li>
<li>If, Else, and Indentation (4:06)</li>
<li>Functions (3:09)</li>
<li>Sequences (2:57)</li>
<li>Collections (3:28)</li>
<li>Working with Sequences (7:27)</li>
<li>Iterating (3:37)</li>
</ul></li>
<li>Working with Files

<ul>
<li>Working with Files (5:29)</li>
<li>Handling Files Easily (1:44)</li>
<li>Working with Directories (3:50)</li>
<li>Working with File Paths - Advanced (6:47)</li>
<li>Iterating Through Files (6:09)</li>
</ul></li>
<li>Downloading Files from FTP Sites

<ul>
<li>Section Intro (1:34)</li>
<li>Navigating Through FTP Directory Trees with Python (7:00)</li>
<li>Storing Python Code (4:32)</li>
<li>Creating an FTP Function (2:29)</li>
<li>Downloading an FTP File (8:32)</li>
<li>Practice No.1: Creating an FTP File Downloader (13:42)</li>
</ul></li>
<li>Working with Archive Files

<ul>
<li>Extracting ZIP, TAR, GZ and Other Archive Formats (3:41)</li>
<li>Extracting RAR Files (1:57)</li>
<li>Practice No.2: Creating a Batch Archive Extractor (5:52)</li>
</ul></li>
<li>Working with TXT and CSV Files

<ul>
<li>Section Intro (1:22)</li>
<li>Reading Delimited TXT and CSV Files (10:06)</li>
<li>Exporting Data from Python to Files (4:14)</li>
<li>Reading Fixed Width Files (1:58)</li>
<li>Exporting Data Back to HTML and Other File Formats (1:02)</li>
<li>Exercise 1 of 6</li>
<li>Solution 1 of 6</li>
</ul></li>
<li>Getting Started with Pandas - a Powerful Data Analysis Library

<ul>
<li>Get Started with Pandas (6:16)</li>
<li>Practice No.3: Calculating and Adding Columns to CSV Files (4:57)</li>
<li>Exercise 2 of 6</li>
<li>Solution 2 of 6</li>
</ul></li>
<li>Concatenating and Joining Tables of Dat a with Pandas

<ul>
<li>Practical No.4: Concatenating Multiple CSV files (6:18)</li>
<li>Exercise 3 of 6</li>
<li>Solution 3 of 6</li>
<li>Practice No. 5: Joining Data Based on a Matching Column (8:59)</li>
<li>Exercise 4 of 6</li>
<li>Solution 4 of 6</li>
<li>Exercise 5 of 6</li>
<li>Solution 5 of 6</li>
</ul></li>
<li>Data Aggregation

<ul>
<li>Practice No. 6: Pivoting Large Amounts of Data (7:41)</li>
</ul></li>
<li>Visualizing Data

<ul>
<li>Data Visualization with Python (11:31)</li>
<li>More Visualization Techniques (12:23)</li>
<li>Practice No. 7: Producing JPG Files (3:08)</li>
<li>Exercise 6 of 6</li>
<li>Solution 6 of 6</li>
</ul></li>
<li>Mapping Spatial Data

<ul>
<li>Programmatically Creating KML Google Earth Files with Python (4:37)</li>
<li>Practice No. 8: Creating KML Google Earth Files from CSV Data (7:46)</li>
</ul></li>
<li>Putting Everything Together

<ul>
<li>User Interaction (6:07)</li>
<li>Practice No. 9: Polishing the Program I (5:00)</li>
<li>Practice No, 10: Polishing the Program II (5:30)</li>
<li>Practice No. 11: Creating Python Modules (5:00)</li>
</ul></li>
<li>Bonus Section: Using Python in Jupyter Notebooks to Boost Productivity

<ul>
<li>Getting Started with Jupyter Notebooks (12:10)</li>
<li>Data Cleaning Project, Part I (8:40)</li>
<li>Data Cleaning Project, Part II (20:18)</li>
</ul></li>
</ul>

    <p class="text-center">
      <a class="open-all" data-target=".course-outline" href>View Full Curriculum</a>
    </p>
  </div>

              </div>
            </div>
            <hr class="product-divider">
            <div id="product-details-11896" class="js-product-details row pagination-details">
              <div class="col-md-6">
                <div id="sc-product-image-carousel11896" class="sc-product-image-carousel carousel slide" data-ride="carousel" data-toughness="0.25" data-interval=false>
  
      <picture><source media="(max-width: 479px)" srcset="https://cdnp3.stackassets.com/f72d75962e2eec9eb06f19f3ff269b2b0692f3ba/store/opt/450/225/3dc2b78b49af7ad54ad4a8b7595fe5358012dc4f397d76b4dc0d9dc2ec0c/f48d9dbda923daf507c6f853f2377b2b106118b5_main_hero_image.jpg" /><source media="(min-width: 480px) and (max-width: 991px)" srcset="https://cdnp3.stackassets.com/9e7999ab448ba9dbf70001719c9de427a5f9b2e3/store/opt/3dc2b78b49af7ad54ad4a8b7595fe5358012dc4f397d76b4dc0d9dc2ec0c/f48d9dbda923daf507c6f853f2377b2b106118b5_main_hero_image.jpg" /><source media="(min-width: 992px) and (max-width: 1199px)" srcset="https://cdnp3.stackassets.com/1763546d5df3eb89d6c4dae0a208cce9c7b797f0/store/opt/489/244/3dc2b78b49af7ad54ad4a8b7595fe5358012dc4f397d76b4dc0d9dc2ec0c/f48d9dbda923daf507c6f853f2377b2b106118b5_main_hero_image.jpg" /><img class="img-responsive" src="https://cdnp3.stackassets.com/03148c303bd3af80925f3fe622b11452eb56476a/store/opt/596/298/3dc2b78b49af7ad54ad4a8b7595fe5358012dc4f397d76b4dc0d9dc2ec0c/f48d9dbda923daf507c6f853f2377b2b106118b5_main_hero_image.jpg" alt="F48d9dbda923daf507c6f853f2377b2b106118b5 main hero image" /></picture>
</div>


                    <div class="bubble-bundle-page-product-details text-center">
                      <div class="bubble">
  <div class="title">Access</div>
  <div class="value">Lifetime</div>
</div>

                      <div class="bubble">
  <div class="title">Content</div>
  <div class="value">21.50 hours</div>
</div>

                      <div class="bubble">
  <div class="title">Lessons</div>
  <div class="value">172</div>
</div>

                    </div>
              </div>
              <div class="col-md-6 course">
                <h3><strong>The Python Mega Course: Build 10 Real World Applications</strong></h3>
                <h4>
                  Explore the Power of Python By Actually Building Apps With Python
                </h4>

                <p>
                  By <a class="brand-primary anchor-link instructor-link" href="#product_11896-instructor">Ardit Sulce</a>
                    | in <a class="brand-primary" href="/collections/online-courses">Online Courses</a>
                </p>
                  <div class="bundle-page-product-details">
  
  <ul class="nav nav-tabs " role="tablist">
      <li class="col-xs-4 active primary-border-bottom-active">
        <a data-toggle="tab"
          id="product_11896-description"
          role="tab"
          class="text-capitalize js-product-detail"
          href="#product_11896-description-content">
          Description
        </a>
</li>      <li class="col-xs-4  primary-border-bottom-active">
        <a data-toggle="tab"
          id="product_11896-instructor"
          role="tab"
          class="text-capitalize js-product-detail"
          href="#product_11896-instructor-content">
          Instructor
        </a>
</li>      <li class="col-xs-4  primary-border-bottom-active">
        <a data-toggle="tab"
          id="product_11896-specs"
          role="tab"
          class="text-capitalize js-product-detail"
          href="#product_11896-specs-content">
          Specs
        </a>
</li>  </ul>

  <div class="tab-content">
    <div class="tab-pane active fade in" id="product_11896-description-content" role="tabpanel">
      The best way to learn Python is by using Python, and this massive course will teach you while you develop real life applications. Over the course, you'll truly begin to appreciate the many, many uses of Python as you build web applications, database applications, web visualizations, and much more. By course's end, you will have built 10 applications that you can be proud of, and have the tools to go off on your own into the world of Python programming.
<br><br>
<ul><li>Access 172 lectures & 21.5 hours of content 24/7
<li>Build a name generator, a website URL timed blocker, a web map generator, a portfolio website w/ Flask, a GUI-based desktop application, a webcam motion detector, a web scraper of property, an interactive web-based financial chart, a data collector web application, a geocoding web service
<li>Under & use object-oriented design
<li>Use Python to build applications w/ Flask, Tkinter, Numpy, Folium & more
<li>Explore scraping data, computer vision, sending automated emails & more using Python
<li>Schedule Python programs based on computer events</ul>
    </div>
    <div class="tab-pane  fade in" id="product_11896-instructor-content" role="tabpanel">
      Ardit Sulce received his master's degree in Geospatial Technologies from the Institute of Geoinformatics at University of Muenster, Germany. He also holds a Bachelor's degree in Geodetic Engineering.

Ardit offers his expertise in Python development on Upwork where he has worked with companies such as the Swiss in-Terra, Center for Conservation Geography, and Rapid Intelligence. He is the founder of PythonHow where he authors written tutorials about the Python programming language.
    </div>
    <div class="tab-pane  fade in" id="product_11896-specs-content" role="tabpanel">
      <p>Details & Requirements</p><ul><li>Length of time users can access this course: lifetime
<li>Access options: web streaming
<li>Certification of completion  not included
<li>Redemption deadline: redeem your code within 30 days of purchase
<li>Experience level required: all levels</ul><p>Compatibility<br></p><ul><li>Internet required</ul>
    </div>
  </div>

</div>

  <div class="course-outline inactive">
    <h4 class="title">Course Outline <i class="fa sc-display-outline pull-right"></i></h4>

      <ul>
<li>Getting Started

<ul>
<li>Course Introduction (4:14)</li>
<li>Tips for Learning Efficiency (3:04)</li>
<li>The Companion Cheatsheet (1:04)</li>
<li>Three Typical Python Programs</li>
<li>Installing Python</li>
<li>Creating a Basic Python program</li>
<li>Python Components</li>
</ul></li>
<li>Variables and Functions

<ul>
<li>Variables</li>
<li>Functions</li>
<li>Using the Python Interactive Shell</li>
<li>Setting up and Working with the Atom Editor</li>
</ul></li>
<li>Data Types

<ul>
<li>Numbers</li>
<li>More on Numbers: Using Python as a Calculator</li>
<li>Strings</li>
<li>Lists and Tuples</li>
<li>Dictionaries</li>
<li>Summary of Datatypes</li>
</ul></li>
<li>Conditionals

<ul>
<li>Conditional Blocks</li>
<li>In-line Conditionals</li>
</ul></li>
<li>Loops and User Input

<ul>
<li>Loops</li>
<li>For Loops</li>
<li>User Input</li>
<li>While Loop</li>
<li>For Loop with Multiple Lists</li>
</ul></li>
<li>File Handling

<ul>
<li>Introduction to File Handling</li>
<li>Opening and Reading a File</li>
<li>Opening and Writing Text to a Text Fle</li>
<li>Appending to a Text File</li>
<li>The Rest of File Handling Methods</li>
<li>The &quot;With&quot; Statement</li>
</ul></li>
<li>More Functionalities

<ul>
<li>Introduction</li>
<li>Modules, Libraries, and Packages</li>
<li>Commenting and Documenting your Code</li>
<li>Lecture 3 Dates and times</li>
</ul></li>
<li>Application 1: Building a Text Generator

<ul>
<li>Demonstration of the Text Generator Application</li>
<li>Building Version 1</li>
<li>Building Version 2</li>
<li>Building Version 3</li>
</ul></li>
<li>Data Analysis with Pandas

<ul>
<li>What is Pandas</li>
<li>Getting Started with Pandas</li>
<li>Getting Started with Jupyter Notebooks</li>
<li>Loading Data in Python fro CSV, TXT, Excel and JSON Files</li>
<li>Indexing and Slicing Dataframes</li>
<li>Dropping Dataframe Columns and Rows</li>
<li>Updating and Adding New Columns and Rows</li>
<li>Example: Geocoding Addresses with Pandas and Geopy</li>
</ul></li>
<li>Numpy

<ul>
<li>What is Numpy</li>
<li>Creating Numpy Arrays from Images and Vice-Versa</li>
<li>Indexing, Slicing and Iterating</li>
<li>Stacking and Splitting</li>
</ul></li>
<li>Application 2: Creating Leaflet Webmaps with Python and Folium

<ul>
<li>Demonstration of the Web Mapping Application</li>
<li>Creating an Open Street Map with Python</li>
<li>Adding Markers to the Map</li>
<li>Adding Markers to the Map from CSV Data</li>
<li>Rule-based Coloring of Markers</li>
<li>More on Rule-based Styling</li>
<li>Calculating the Map Center from the Input Data</li>
<li>Adjusting the Code for the Latest Version of Folium</li>
<li>Adding a Choropleth Map from GeoJson</li>
<li>Adding a Layer Control Panel</li>
</ul></li>
<li>Application 3: Building a Website Blocker

<ul>
<li>Demonstration of the Website Blocker Application</li>
<li>Application Architecture</li>
<li>Setting up the Script</li>
<li>Setting up the Infinite Loop</li>
<li>Implementing the First Part</li>
<li>Implementing the Second Part</li>
<li>Scheduling the Python Program on Windows</li>
<li>Scheduling the Python Program on Mac and Linux</li>
</ul></li>
<li>Application 4: Building a Website with Python and Flask

<ul>
<li>Demonstration of the Website</li>
<li>Building Your First Website</li>
<li>Returning HTML Templates</li>
<li>Adding a Navigation Menu</li>
<li>Adding CSS Styling</li>
<li>Creating a Python Virtual Environment</li>
<li>Deploying the Website to a Live Server</li>
<li>Maintaining the Website</li>
</ul></li>
<li>Building Graphical User Interfaces with Tkinter

<ul>
<li>Introduction to Tkinter</li>
<li>Setting up a GUI with Widgets</li>
<li>Connecting GUI Widgets with Callback Functions</li>
</ul></li>
<li>Python for Interacting with SQLite and PostgreSQL Databases

<ul>
<li>Introduction to Working with Databases</li>
<li>Connecting and Inserting Data to SQLite via Python</li>
<li>Selecting, Inserting, Deleting, and Updating SQLite Records</li>
<li>Introduction to PostgreSQL Psycopg2</li>
<li>Selecting, Inserting, Deleting, and Updating PostgreSQL Records</li>
</ul></li>
<li>Application 5: Building a Desktop Database Application

<ul>
<li>Demonstration of the Database Application</li>
<li>User Interface Design</li>
<li>Building the Front-end Interface</li>
<li>Building the Back-end</li>
<li>Connecting the Front-end to the Back-end, Part 1</li>
<li>Connecting the Front-end to the Back-end, Part 2</li>
<li>Creating a Standalone Executable Version of the Program</li>
</ul></li>
<li>Object Oriented Programming

<ul>
<li>Object Oriented Programming Explained</li>
<li>Turning this Application into OOP Style, Part 1</li>
<li>Turning this Application into OOP Style, Part 2</li>
<li>Creating a Bank Account Object</li>
<li>Inheritance</li>
<li>OOP Glossary</li>
</ul></li>
<li>Python for Image and Video Processing with OpenCV

<ul>
<li>Introduction</li>
<li>Installing OpenCV for Python</li>
<li>Loading, Displaying, Resizing, and Writing Images with Python</li>
<li>Face Detection</li>
<li>Capturing Video</li>
</ul></li>
<li>Application 6: Building a Webcam Motion Detector

<ul>
<li>Demonstration of the Motion Detector Application</li>
<li>Detecting Objects from the Webcam</li>
<li>Recording Motion Time</li>
</ul></li>
<li>Python for Interactive Data Visualization on the Browser

<ul>
<li>Introduction to Bokeh</li>
<li>The Bokeh Charts Interface</li>
<li>The Bokeh Plotting Interface</li>
<li>Customizing Pot Styles</li>
<li>Understanding the Structure Behind the Graphs</li>
<li>Time-series Plots</li>
<li>More Visualization Examples with Bokeh</li>
<li>Plotting Time Intervals of the Motion Detector</li>
<li>Hover Tool Implementation</li>
</ul></li>
<li>Webscraping

<ul>
<li>Section Introduction</li>
<li>The Concept Behind Webscraping</li>
<li>Scraping a Webpage with Requests and BeautifulSoup</li>
</ul></li>
<li>Application 7: Scraping Real Estate Property Data

<ul>
<li>Demonstration of the Webscraping Application</li>
<li>Understanding the Problem and Loading the Webpage in Python</li>
<li>Extracting Divisions of All Properties</li>
<li>Extracting Addresses and Property Details</li>
<li>Extracting Elements with no Unique Identifiers</li>
<li>Saving the Extracted Data in CSV Files</li>
<li>Crawling Through Webpages</li>
</ul></li>
<li>Application 8: Building a Web-based Financial Graph

<ul>
<li>Demonstration of the Financial Analysis Application</li>
<li>Downloading Various Datasets with Python</li>
<li>Understanding Stock Market Data</li>
<li>Understanding Stock Market Data Candlestick Charts</li>
<li>Building Chart Candlesticks with Bokeh Quadrants</li>
<li>Building Chart Candlesticks with Bokeh Rectangles</li>
<li>Building Candlestick Segments</li>
<li>Stylizing the Chart</li>
<li>The Concept Behind Embedding a Bokeh Chart in a Webpage</li>
<li>Embedding the Bokeh Chart in a Webpage</li>
<li>Deploying the Chart Website to a Live Server</li>
</ul></li>
<li>Application 9: Building a Data Collector Web App

<ul>
<li>Demonstration of the Web Application</li>
<li>Steps for Building a PostgreSQL Database-enabled Web Application</li>
<li>Building the Front-end: HTML Part</li>
<li>Building the Front-end: CSS Part</li>
<li>Building the Back-end: Getting User Input</li>
<li>Building the Back End: Creating the PostGreSQL Database Model</li>
<li>Building the Back End: Storing User Data to the Database</li>
<li>Building the Back End: Emailing Database Values Back to the User</li>
<li>Building the Back End: Sending Statistics to Users</li>
<li>Deploying the Web Application to a Live Server</li>
<li>Bonus Lecture: User Downloads and Uploads</li>
</ul></li>
<li>Application 10: Student Project on Building a Geocoder Web Service

<ul>
<li>Demonstration of the Geocoding Web Service Application and Project Requirements</li>
<li>Solution, Part 1</li>
<li>Solution, Part 2</li>
<li>End of the Course (0:47)</li>
</ul></li>
</ul>

    <p class="text-center">
      <a class="open-all" data-target=".course-outline" href>View Full Curriculum</a>
    </p>
  </div>

              </div>
            </div>
            <hr class="product-divider">
            <div id="product-details-10885" class="js-product-details row pagination-details">
              <div class="col-md-6">
                <div id="sc-product-image-carousel10885" class="sc-product-image-carousel carousel slide" data-ride="carousel" data-toughness="0.25" data-interval=false>
  
      <picture><source media="(max-width: 479px)" srcset="https://cdnp3.stackassets.com/5d76c67eebdf2bf2e1a7735007d7395f6d532150/store/opt/450/225/cd1cd108de898fd31b7ab9991c4c832de2c67c8272dba6a8d086ee9c6473/ca050360cae8fc511626ce9f91b1c6db5f0c2e14_main_hero_image.jpg" /><source media="(min-width: 480px) and (max-width: 991px)" srcset="https://cdnp3.stackassets.com/3501fa11fa19bf5034b4bb27412bf5a170a757c0/store/opt/cd1cd108de898fd31b7ab9991c4c832de2c67c8272dba6a8d086ee9c6473/ca050360cae8fc511626ce9f91b1c6db5f0c2e14_main_hero_image.jpg" /><source media="(min-width: 992px) and (max-width: 1199px)" srcset="https://cdnp3.stackassets.com/0eed23fbedba24484aea94f58ac665c644662a04/store/opt/489/244/cd1cd108de898fd31b7ab9991c4c832de2c67c8272dba6a8d086ee9c6473/ca050360cae8fc511626ce9f91b1c6db5f0c2e14_main_hero_image.jpg" /><img class="img-responsive" src="https://cdnp3.stackassets.com/b22456a9bf7f53d43089c62a5f84c48bad480457/store/opt/596/298/cd1cd108de898fd31b7ab9991c4c832de2c67c8272dba6a8d086ee9c6473/ca050360cae8fc511626ce9f91b1c6db5f0c2e14_main_hero_image.jpg" alt="Ca050360cae8fc511626ce9f91b1c6db5f0c2e14 main hero image" /></picture>
</div>


                    <div class="bubble-bundle-page-product-details text-center">
                      <div class="bubble">
  <div class="title">Access</div>
  <div class="value">Lifetime</div>
</div>

                      <div class="bubble">
  <div class="title">Content</div>
  <div class="value">7 hours</div>
</div>

                      <div class="bubble">
  <div class="title">Lessons</div>
  <div class="value">43</div>
</div>

                    </div>
              </div>
              <div class="col-md-6 course">
                <h3><strong>The Complete Computer Vision Course with Python</strong></h3>
                <h4>
                  Contribute to the Next Generation of Consumer &amp; Enterprise Applications
                </h4>

                <p>
                  By <a class="brand-primary anchor-link instructor-link" href="#product_10885-instructor">Zenva</a>
                    | in <a class="brand-primary" href="/collections/online-courses">Online Courses</a>
                </p>
                  <div class="bundle-page-product-details">
  
  <ul class="nav nav-tabs " role="tablist">
      <li class="col-xs-4 active primary-border-bottom-active">
        <a data-toggle="tab"
          id="product_10885-description"
          role="tab"
          class="text-capitalize js-product-detail"
          href="#product_10885-description-content">
          Description
        </a>
</li>      <li class="col-xs-4  primary-border-bottom-active">
        <a data-toggle="tab"
          id="product_10885-instructor"
          role="tab"
          class="text-capitalize js-product-detail"
          href="#product_10885-instructor-content">
          Instructor
        </a>
</li>      <li class="col-xs-4  primary-border-bottom-active">
        <a data-toggle="tab"
          id="product_10885-specs"
          role="tab"
          class="text-capitalize js-product-detail"
          href="#product_10885-specs-content">
          Specs
        </a>
</li>  </ul>

  <div class="tab-content">
    <div class="tab-pane active fade in" id="product_10885-description-content" role="tabpanel">
      Have you ever wondered how things like self-driving cars, Google image searches, Snapchat and Instagram filters are created? While there are many answers to this question, the umbrella answer is computer vision. In this course, you'll use Python to build a variety of tools that reflect the broad range of computer vision techniques. These technologies are powering the next generation of consumer and enterprise applications and the time to jump in the game is now!
<br><br>
<ul><li>Access 43 lectures & 7 hours of content 24/7
<li>Build a receipt segmenter to find text in an image
<li>Count coins & dollar bills in an image after creating a currency counter
<li>Find Legend of Zelda rupees using a pattern matching algorithm
<li>Design a face swapping app
<li>Discuss the mathematical theory & processes behind computer vision
<li>Understand fundamental computer vision & image processing techniques</ul>
    </div>
    <div class="tab-pane  fade in" id="product_10885-instructor-content" role="tabpanel">
      Pablo Farias Navarro is a software developer and founder of ZENVA. Since 2012, Pablo has been teaching online how to create games, apps and websites to over 150,000 students through the Udemy and Zenva Academy platforms, and created content for companies such as Amazon and Intel. Pablo is a member of the Intel Innovator Program in the Asia Pacific, and has run live programming workshops in San Francisco, Brisbane and Bangalore. Pablo holds a Master in Information Technology (Management) degree from the University of Queensland (Australia) and a Master of Science in Engineering degree from the Catholic University of Chile.
    </div>
    <div class="tab-pane  fade in" id="product_10885-specs-content" role="tabpanel">
      <p>Details & Requirements</p>

<ul><li>Length of time users can access this course: lifetime
<li>Access options: web streaming, mobile streaming
<li>Certification of completion not included
<li>Redemption deadline: redeem your code within 30 days of purchase
<li>Experience level required: all levels</ul>

<p>Compatibility</p><ul><li>Internet required</ul>
    </div>
  </div>

</div>

  <div class="course-outline inactive">
    <h4 class="title">Course Outline <i class="fa sc-display-outline pull-right"></i></h4>

      <ul>
<li>The Complete Computer Vision Course with Python

<ul>
<li>Course Intro (6:35)</li>
<li>Course source code</li>
<li>Configuring the Environment (6:06)</li>
<li>Image Representations (11:11)</li>
<li>OpenCV Basics (9:59)</li>
<li>Brightness and Contrast (5:56)</li>
<li>OpenCV Brightness and Contrast (9:38)</li>
<li>Image Blending (4:20)</li>
<li>OpenCV Image Blending (7:31)</li>
<li>Drawing on Images (11:31)</li>
<li>OpenCV Drawing on Images (8:02)</li>
<li>Basic Thresholding (9:31)</li>
<li>OpenCV Basic Thresholding (11:17)</li>
<li>Otsu Binarization (7:35)</li>
<li>OpenCV Otsu Binarization (5:05)</li>
<li>Adaptive Threshold (8:15)</li>
<li>OpenCV Adaptive Threshold (7:21)</li>
<li>Kernels (15:47)</li>
<li>Fundamental Morphological Operators (9:19)</li>
<li>OpenCV Fundamental Morphological Operators (11:59)</li>
<li>Composite Morphological Operators (5:53)</li>
<li>OpenCV Composite Morphological Operators (5:43)</li>
<li>Morphological Filters (12:31)</li>
<li>Normalized Box Filter (11:29)</li>
<li>Gaussian Filter (11:55)</li>
<li>Median Filter (11:46)</li>
<li>Bilateral Filter (13:37)</li>
<li>Image Derivatives (15:01)</li>
<li>Sobel Derivative (11:59)</li>
<li>Laplace Derivative (8:21)</li>
<li>Canny Edge Detection (16:19)</li>
<li>Introduction to Contours (11:26)</li>
<li>Contour Detection (5:21)</li>
<li>Bounding Boxes (8:29)</li>
<li>Template Matching Metrics (14:15)</li>
<li>Region of Interest (9:29)</li>
<li>Support Vector Machines (15:13)</li>
<li>Decision Trees (17:06)</li>
<li>AdaBoost (10:47)</li>
<li>Introduction to Cascade Classifiers (10:15)</li>
<li>OpenCV Cascade Classifiers (15:05)</li>
<li>Course Outro (7:24)</li>
</ul></li>
</ul>

    <p class="text-center">
      <a class="open-all" data-target=".course-outline" href>View Full Curriculum</a>
    </p>
  </div>

              </div>
            </div>
            <hr class="product-divider">
            <div id="product-details-10376" class="js-product-details row pagination-details">
              <div class="col-md-6">
                <div id="sc-product-image-carousel10376" class="sc-product-image-carousel carousel slide" data-ride="carousel" data-toughness="0.25" data-interval=false>
  
      <picture><source media="(max-width: 479px)" srcset="https://cdnp2.stackassets.com/6cad0fe392ef249dae59acac12f7ed04861fded8/store/opt/450/225/7368c310c5498f7e009aaffe3de0fb2c8f96e21f2fa846853d4f33e3cc96/7ea43f759d45473302a896131902a7296eba0f0f_main_hero_image.jpg" /><source media="(min-width: 480px) and (max-width: 991px)" srcset="https://cdnp2.stackassets.com/10bbb37d5210ceacdf35132201e7b2b6e1f008f8/store/opt/7368c310c5498f7e009aaffe3de0fb2c8f96e21f2fa846853d4f33e3cc96/7ea43f759d45473302a896131902a7296eba0f0f_main_hero_image.jpg" /><source media="(min-width: 992px) and (max-width: 1199px)" srcset="https://cdnp2.stackassets.com/972569f38ffb5978e371cdc02660cc194896d520/store/opt/489/244/7368c310c5498f7e009aaffe3de0fb2c8f96e21f2fa846853d4f33e3cc96/7ea43f759d45473302a896131902a7296eba0f0f_main_hero_image.jpg" /><img class="img-responsive" src="https://cdnp2.stackassets.com/3e1ad4242b70d05ef49c67338705bdfbc7c02789/store/opt/596/298/7368c310c5498f7e009aaffe3de0fb2c8f96e21f2fa846853d4f33e3cc96/7ea43f759d45473302a896131902a7296eba0f0f_main_hero_image.jpg" alt="7ea43f759d45473302a896131902a7296eba0f0f main hero image" /></picture>
</div>


                    <div class="bubble-bundle-page-product-details text-center">
                      <div class="bubble">
  <div class="title">Access</div>
  <div class="value">Lifetime</div>
</div>

                      <div class="bubble">
  <div class="title">Content</div>
  <div class="value">7 hours</div>
</div>

                      <div class="bubble">
  <div class="title">Lessons</div>
  <div class="value">54</div>
</div>

                    </div>
              </div>
              <div class="col-md-6 course">
                <h3><strong>Learn Python 3 from Scratch</strong></h3>
                <h4>
                  Build System Securities &amp; Connect Your Hardware Using Python
                </h4>

                <p>
                  By <a class="brand-primary anchor-link instructor-link" href="#product_10376-instructor">Let&#39;s Kode It</a>
                    | in <a class="brand-primary" href="/collections/online-courses">Online Courses</a>
                </p>
                  <div class="bundle-page-product-details">
  
  <ul class="nav nav-tabs " role="tablist">
      <li class="col-xs-4 active primary-border-bottom-active">
        <a data-toggle="tab"
          id="product_10376-description"
          role="tab"
          class="text-capitalize js-product-detail"
          href="#product_10376-description-content">
          Description
        </a>
</li>      <li class="col-xs-4  primary-border-bottom-active">
        <a data-toggle="tab"
          id="product_10376-instructor"
          role="tab"
          class="text-capitalize js-product-detail"
          href="#product_10376-instructor-content">
          Instructor
        </a>
</li>      <li class="col-xs-4  primary-border-bottom-active">
        <a data-toggle="tab"
          id="product_10376-specs"
          role="tab"
          class="text-capitalize js-product-detail"
          href="#product_10376-specs-content">
          Specs
        </a>
</li>  </ul>

  <div class="tab-content">
    <div class="tab-pane active fade in" id="product_10376-description-content" role="tabpanel">
      Python is a great programming language to learn in conjunction with your new Wio Link, as you can also connect to the Rest API to communicate with your board in Python. Overall demand for Python programming has exploded in recent years as many industries are rapidly transitioning to Python and building automation tools. This comprehensive course will introduce you to the basics of Python 3, the newest series of this powerful coding language. Give yourself a leg up over other developers by adding Python to your programming repertoire.
<br><br>
<ul><li>Access 7 hours of video & 54 lectures 24/7
<li>Learn back-end programming for web applications, games & in-house scripts
<li>Study any time w/ video screencast & easily accessible code files
<li>Test your knowledge w/ quizzes & homework
<li>Learn coding best practices</ul>
    </div>
    <div class="tab-pane  fade in" id="product_10376-instructor-content" role="tabpanel">
      Let's Kode It is the best place to learn all computer related skills including coding, testing, web development or Microsoft Word, Excel, Powerpoint.
    </div>
    <div class="tab-pane  fade in" id="product_10376-specs-content" role="tabpanel">
      <p>Details & Requirements</p><ul><li>Length of time users can access this course: lifetime
<li>Access options: web streaming, mobile streaming
<li>Certification of completion included
<li>Redemption deadline: redeem your code within 30 days of purchase
<li>Experience level required: all levels</ul>

<p>Compatibility</p>
<ul><li>Internet required</ul>
    </div>
  </div>

</div>

  <div class="course-outline inactive">
    <h4 class="title">Course Outline <i class="fa sc-display-outline pull-right"></i></h4>

      <ul>
<li>Introduction

<ul>
<li>Instructor Introduction (1:19)</li>
<li>How to reach me anytime (2:40)</li>
</ul></li>
<li>Setup And Configuration

<ul>
<li>Python Installation - Windows (3:52)</li>
<li>Configuration Of Python - Windows (4:19)</li>
<li>Python Installation And Setup - Mac (9:17)</li>
<li>Package Management Using PIP (8:04)</li>
<li>IDE Options For Python Development (5:46)</li>
<li>Installing iPython (0:06)</li>
</ul></li>
<li>Understanding Variables And Data Type

<ul>
<li>Python Terminal Walkthrough (11:45)</li>
<li>Understanding Objects And References (12:01)</li>
<li>Variables Rules (7:24)</li>
<li>Numbers Data Type And Math Operations (7:26)</li>
<li>Numbers - Exponentiation And Modulo (5:44)</li>
<li>Arithmetic Order Of Precedence (6:51)</li>
<li>Boolean Data Type (6:02)</li>
<li>Working With Strings (9:33)</li>
<li>String Methods - Part 1 (10:59)</li>
<li>String-Methods - Part 2 (8:10)</li>
<li>More String Slicing And Indexing (7:41)</li>
<li>Strings Formatting (5:10)</li>
</ul></li>
<li>Advanced Data Types

<ul>
<li>List And Accessing The Elements (7:54)</li>
<li>List Methods (10:53)</li>
<li>Working With Dictionary (10:34)</li>
<li>Nested Dictionary (7:03)</li>
<li>Dictionary Methods (6:41)</li>
<li>Working With Tuple (6:28)</li>
</ul></li>
<li>Comparison And Boolean Operators

<ul>
<li>Working With Comparators (9:49)</li>
<li>Understanding Boolean Operators (7:10)</li>
<li>Boolean Operators - Order Of Precedence (7:41)</li>
</ul></li>
<li>Program Control Flow

<ul>
<li>Conditional Logic - If Else Conditions (11:19)</li>
<li>While Loop Demo (7:49)</li>
<li>Break Continue And WhileElse (9:42)</li>
<li>For Loop Demo (11:25)</li>
<li>Iterating Multiple Lists - Using the Zip Function (3:49)</li>
<li>Using Range Function In For Loop (8:35)</li>
</ul></li>
<li>Methods - Working With Reusable Code

<ul>
<li>Understanding Methods (10:27)</li>
<li>Working With Return Values (12:32)</li>
<li>Working With Positional - Optional Parameters (7:21)</li>
<li>Understanding Variable Scope (10:15)</li>
<li>More Built-In Functions (9:45)</li>
<li>Exercise With Solution - Homework (10:33)</li>
</ul></li>
<li>Classes - Object Oriented Programming

<ul>
<li>Understanding Objects And Classes (9:15)</li>
<li>Create Your Own Object (12:37)</li>
<li>Create Your Own Methods (8:58)</li>
<li>Inheritance (8:07)</li>
<li>Method Overriding (8:47)</li>
<li>Exercise With Solution - Homework (4:02)</li>
</ul></li>
<li>Exception Handling

<ul>
<li>Exception Handling Demo (10:17)</li>
<li>Finally And Else Block (7:38)</li>
<li>Exercise With Solution - Homework (3:28)</li>
</ul></li>
<li>Modules

<ul>
<li>Builtin Modules (8:54)</li>
<li>Create Your Own Modules (6:42)</li>
</ul></li>
<li>Conclusion

<ul>
<li>BONUS: What&#39;s Next and other cool free stuff (2:20)</li>
</ul></li>
</ul>

    <p class="text-center">
      <a class="open-all" data-target=".course-outline" href>View Full Curriculum</a>
    </p>
  </div>

              </div>
            </div>
            <hr class="product-divider">
            <div id="product-details-10435" class="js-product-details row pagination-details">
              <div class="col-md-6">
                <div id="sc-product-image-carousel10435" class="sc-product-image-carousel carousel slide" data-ride="carousel" data-toughness="0.25" data-interval=false>
  
      <picture><source media="(max-width: 479px)" srcset="https://cdnp0.stackassets.com/44ee68477b7875e61a2612343d3da27de40a344f/store/opt/450/225/361e55053c45f440c2928a012c5cfc378d6c2aac0f61a2b20dced56e7770/bec94f72ee0a95e38537bc5412aa17eeec38168e_main_hero_image.jpg" /><source media="(min-width: 480px) and (max-width: 991px)" srcset="https://cdnp0.stackassets.com/6fecef05f78aaf12a32d3b62de3fec78930c03fa/store/opt/361e55053c45f440c2928a012c5cfc378d6c2aac0f61a2b20dced56e7770/bec94f72ee0a95e38537bc5412aa17eeec38168e_main_hero_image.jpg" /><source media="(min-width: 992px) and (max-width: 1199px)" srcset="https://cdnp0.stackassets.com/5a8f85e63395580a6ef11313fcb56c061985552c/store/opt/489/244/361e55053c45f440c2928a012c5cfc378d6c2aac0f61a2b20dced56e7770/bec94f72ee0a95e38537bc5412aa17eeec38168e_main_hero_image.jpg" /><img class="img-responsive" src="https://cdnp0.stackassets.com/6cda44be2d907179a6ccac0d0e99632006be13da/store/opt/596/298/361e55053c45f440c2928a012c5cfc378d6c2aac0f61a2b20dced56e7770/bec94f72ee0a95e38537bc5412aa17eeec38168e_main_hero_image.jpg" alt="Bec94f72ee0a95e38537bc5412aa17eeec38168e main hero image" /></picture>
</div>


                    <div class="bubble-bundle-page-product-details text-center">
                      <div class="bubble">
  <div class="title">Access</div>
  <div class="value">Lifetime</div>
</div>

                      <div class="bubble">
  <div class="title">Content</div>
  <div class="value">13.50 hours</div>
</div>

                      <div class="bubble">
  <div class="title">Lessons</div>
  <div class="value">157</div>
</div>

                    </div>
              </div>
              <div class="col-md-6 course">
                <h3><strong>Python Tutorial: Python Network Programming - Build 7 Apps</strong></h3>
                <h4>
                  Learn to Write Powerful Code by Building Apps from Scratch
                </h4>

                <p>
                  By <a class="brand-primary anchor-link instructor-link" href="#product_10435-instructor">Mihai Catalin Teodosiu</a>
                    | in <a class="brand-primary" href="/collections/online-courses">Online Courses</a>
                </p>
                  <div class="bundle-page-product-details">
  
  <ul class="nav nav-tabs " role="tablist">
      <li class="col-xs-4 active primary-border-bottom-active">
        <a data-toggle="tab"
          id="product_10435-description"
          role="tab"
          class="text-capitalize js-product-detail"
          href="#product_10435-description-content">
          Description
        </a>
</li>      <li class="col-xs-4  primary-border-bottom-active">
        <a data-toggle="tab"
          id="product_10435-instructor"
          role="tab"
          class="text-capitalize js-product-detail"
          href="#product_10435-instructor-content">
          Instructor
        </a>
</li>      <li class="col-xs-4  primary-border-bottom-active">
        <a data-toggle="tab"
          id="product_10435-specs"
          role="tab"
          class="text-capitalize js-product-detail"
          href="#product_10435-specs-content">
          Specs
        </a>
</li>  </ul>

  <div class="tab-content">
    <div class="tab-pane active fade in" id="product_10435-description-content" role="tabpanel">
      Over 10000 satisfied students have enrolled in this highly-rated Python courses across the Web. Why? Because this course will teach you essential Python concepts that are extremely relevant in any tech career, not to mention perfect for building amazing network tools. Follow along with the below hands-on projects, and you'll solidify the concepts and skills you need to confidently code with Python.
<br><br>
<ul><li>Learn & practice every Python key concept w/ 13.5 hours & 157 lectures
<li>Follow each lesson w/ a short quiz that helps consolidate the main ideas 
<li>Dive right into real-life network scenarios & apply your knowledge to build 7 great network tools
<li>Utilize the provided virtual machine w/ all Python modules installed & full source code included
<li>Build a variety of apps:
<ul><li>Subnet calculator
<li>Configuring multiple network devices concurrently via SSH or Telnet
<li>DHCP client simulator for testing a DHCP server in the local network
<li>and more!</ul></ul>
    </div>
    <div class="tab-pane  fade in" id="product_10435-instructor-content" role="tabpanel">
      Mihai Catalin Teodosiu holds a degree in Telecommunications and Information Technology from University Politehnica of Bucharest, Romania, as well as the CCNP, CCNA, CCDA, JNCIA, and ISTQB CTFL certifications. He has been working as a Network Quality Assurance Engineer since 2010, testing the OS for Nortel/Avaya L3 switches.

<ul><li>5+ years experience in the Networking and Testing/Quality Assurance industries.
<li>Certified professional: Cisco, Juniper & International Software Testing Qualifications Board certifications
<li>Teaching courses on Udemy, GNS3 Academy & other e-learning platforms
<li>Thousands of satisfied students, 4.97 / 5 average course rating
<li>Thousands of followers on LinkedIn, Twitter, Facebook & Blogger</ul>
    </div>
    <div class="tab-pane  fade in" id="product_10435-specs-content" role="tabpanel">
      <p>Details & Requirements</p><ul><li>Length of time users can access this course: lifetime
<li>Access options: web streaming
<li>Certification of completion  not included
<li>Redemption deadline: redeem your code within 30 days of purchase
<li>Experience level required: all levels</ul><p>Compatibility<br></p><ul><li>Internet required</ul>
    </div>
  </div>

</div>

  <div class="course-outline inactive">
    <h4 class="title">Course Outline <i class="fa sc-display-outline pull-right"></i></h4>

      <ul>
<li>Getting Started with Python

<ul>
<li>Course introduction</li>
<li>Introduction to Python</li>
<li>Quick Insight To Get You Warmed Up!</li>
<li>How To Receive Maximum Results From This Course</li>
<li>FAQ - Please Read This In Case You Run Into Any Issues!</li>
<li>Necessary software</li>
<li>Troubleshooting VirtualBox/GNS3 Issues + VM LogIn Credentials</li>
<li>VirtualBox and Virtual Machines - Short Guide (Just Added: Aug 7 2015)</li>
<li>Running a VirtualBox VM within GNS3 v1.X (Just Added: Aug 1st 2015)</li>
<li>List of necessary applications</li>
<li>Python interpreter</li>
<li>Python scripts</li>
<li>Python argument passing</li>
<li>User input</li>
<li>dir and help (2:41)</li>
<li>Quiz 1: Python basics</li>
</ul></li>
<li>Python Data Types

<ul>
<li>Python Variables</li>
<li>Python keywords</li>
<li>Python Data Types</li>
<li>Python Strings</li>
<li>Python String methods</li>
<li>Python String operators and formatting</li>
<li>Python String slices</li>
<li>Quiz 2: Strings</li>
<li>Numbers and math operators</li>
<li>Booleans and logical operators</li>
<li>Quiz 3: Numbers and Booleans</li>
<li>Python Lists introduction</li>
<li>Python List methods</li>
<li>Python List slices</li>
<li>Quiz 4: Lists</li>
<li>Python Sets introduction</li>
<li>Python Set methods</li>
<li>Quiz 5: Sets</li>
<li>Python Tuples introduction</li>
<li>Python Tuple methods</li>
<li>Quiz 6: Tuples</li>
<li>Python Dictionaries introduction</li>
<li>Python Dictionary methods</li>
<li>Conversions between data types</li>
<li>Quiz 7: Dictionaries</li>
</ul></li>
<li>Python Control Flow

<ul>
<li>If / Elif / Else conditionals</li>
<li>For / For-Else loops</li>
<li>While / While-Else loops</li>
<li>If / For / While nesting</li>
<li>Break, Continue, Pass</li>
<li>Python Exceptions</li>
<li>Try / Except / Else / Finally</li>
<li>Quiz 8: Control Flow</li>
</ul></li>
<li>Python Functions

<ul>
<li>Functions</li>
<li>Arguments</li>
<li>Namespaces</li>
<li>Modules and importing</li>
<li>Quiz 9: Functions</li>
</ul></li>
<li>Python File Operations

<ul>
<li>File opening and reading</li>
<li>File writing and appending</li>
<li>File closing / The &quot;with&quot; method</li>
<li>File access modes table</li>
<li>Quiz 10: Files</li>
</ul></li>
<li>Python Regular Expressions

<ul>
<li>The &quot;re.match&quot; and &quot;re.search&quot; methods</li>
<li>The &quot;re.findall&quot; and &quot;re.sub&quot; methods</li>
<li>Python Regular Expressions sheet</li>
<li>Quiz 11: Regular Expressions</li>
</ul></li>
<li>Python Classes (Object-Oriented Programming) Basics

<ul>
<li>Python Classes and Objects</li>
<li>Python Classes and Inheritance</li>
<li>Quiz 12: Classes</li>
</ul></li>
<li>Bonus Python Tools &amp; Resources

<ul>
<li>List / Set / Dictionary comprehensions</li>
<li>Quiz 13: Comprehensions</li>
<li>Python Lambda functions</li>
<li>Quiz 14: Lambda functions</li>
<li>Python Map, Filter, Reduce</li>
<li>Quiz 15: Map, Filter, Reduce</li>
<li>Python Threading basics</li>
<li>How To Install a New Python Module (Just Added: July 1st 2015)</li>
<li>Iterators and Generators (Just Added: Aug 1st 2015)</li>
<li>Itertools (Just Added: September 2 2015)</li>
<li>Decorators (Just Added: September 18 2015)</li>
<li>Sockets: Server (Just Added: November 2 2015)</li>
<li>Socket Server Code (.txt + .py) (Just Added: November 2 2015)</li>
<li>Sockets: Client (Just Added: November 2 2015)</li>
<li>Socket Client Code (.txt + .py) (Just Added: November 2 2015)</li>
<li>Web Access Basics with Python: requests</li>
<li>Some advice on coding</li>
</ul></li>
<li>Setting up the working environment

<ul>
<li>Link to the necessary resources</li>
<li>GNS3 Setup</li>
<li>Linking VirtualBox to the GNS3 network</li>
</ul></li>
<li>Python Networking

<ul>
<li>Python networking with Telnet</li>
<li>Python networking with SSH</li>
<li>Python networking with SNMP</li>
<li>Python networking with Scapy. Creating your own packets.</li>
<li>Code snippet (.pdf + .py): Telnet (Guidelines)</li>
<li>Code snippet (.pdf + .py): SSH (Guidelines)</li>
<li>Code snippet (.pdf + .py): SNMP (Guidelines)</li>
</ul></li>
<li>Python and MySQL

<ul>
<li>Setting up the MySQL database</li>
<li>Python interacting with MySQL</li>
</ul></li>
<li>Application #1 - Basic subnet calculator

<ul>
<li>Short introduction</li>
<li>What are we going to build?</li>
<li>Planning the application</li>
<li>Application #1 - Logical Flow Diagram</li>
<li>Application #1 - Part #1</li>
<li>Application #1 - Part #2</li>
<li>Application #1 - Part #3</li>
<li>Application #1 - Part #4</li>
<li>Testing the application</li>
<li>Entire application code (.pdf + .py)</li>
</ul></li>
<li>Application #2 - SSH/Telnet network configuration

<ul>
<li>What are we going to build?</li>
<li>Planning the application</li>
<li>Application #2 - Logical Flow Diagram</li>
<li>Application #2 - Part #1</li>
<li>Application #2 - Part #2</li>
<li>Application #2 - Part #3</li>
<li>Application #2 - Part #4</li>
<li>Testing the application</li>
<li>Entire SSH application code (.pdf + .py)</li>
<li>Entire Telnet application code (.pdf + .py)</li>
</ul></li>
<li>Application #3 - DHCP client simulator

<ul>
<li>What are we going to build?</li>
<li>Planning the application</li>
<li>Application #3 - Logical Flow Diagram</li>
<li>Application #3 - Part #1</li>
<li>Application #3 - Part #2</li>
<li>Application #3 - Part #3</li>
<li>Application #3 - Part #4</li>
<li>Testing the application</li>
<li>Entire application code (.pdf + .py)</li>
</ul></li>
<li>Application #4 - Network parameters extraction

<ul>
<li>What are we going to build?</li>
<li>Planning the application</li>
<li>Application #4 - Logical Flow Diagram</li>
<li>Application #4 - Part #1</li>
<li>Application #4 - Part #2</li>
<li>Application #4 - Part #3</li>
<li>Application #4 - Part #4</li>
<li>Application #4 - Part #5</li>
<li>Testing the application</li>
<li>Entire application code (.pdf + .py)</li>
</ul></li>
<li>Application #5 - OSPF network discovery via SNMP

<ul>
<li>What are we going to build?</li>
<li>Planning the application</li>
<li>Application #5 - Logical Flow Diagram</li>
<li>Application #5 - Part #1</li>
<li>Application #5 - Part #2</li>
<li>Application #5 - Part #3</li>
<li>Application #5 - Part #4</li>
<li>Application #5 - Part #5</li>
<li>Application #5 - Part #6</li>
<li>Testing the application</li>
<li>Entire application code (.pdf + .py)</li>
</ul></li>
<li>[NEW] Application #6 - Basic network sniffer

<ul>
<li>Application #6 - Guidelines</li>
<li>Application #6 - Logical Flow Diagram</li>
<li>Entire application code (.pdf + .py)</li>
</ul></li>
<li>[NEW] Application #7 - Configuration file comparator

<ul>
<li>Application #7 - Guidelines</li>
<li>Application #7 - Logical Flow Diagram</li>
<li>Entire application code (.pdf + .py)</li>
</ul></li>
<li>Practice, Practice, Practice...

<ul>
<li>100 Python Exercises (Just Added: June 10 2015)</li>
<li>Answers for All the Exercises (Just Added: June 10 2015)</li>
<li>Project - Homework (Just Added: June 16 2015)</li>
<li>Let&#39;s Stay In Touch!</li>
<li>Please Read This Carefully!</li>
<li>Bonus Lecture: More Python Networking Training</li>
</ul></li>
</ul>

    <p class="text-center">
      <a class="open-all" data-target=".course-outline" href>View Full Curriculum</a>
    </p>
  </div>

              </div>
            </div>
            <hr class="product-divider">
            <div id="product-details-11186" class="js-product-details row pagination-details">
              <div class="col-md-6">
                <div id="sc-product-image-carousel11186" class="sc-product-image-carousel carousel slide" data-ride="carousel" data-toughness="0.25" data-interval=false>
  
      <picture><source media="(max-width: 479px)" srcset="https://cdnp1.stackassets.com/7ebb4a53897c22758f86c181d949bcc393fff19e/store/opt/450/225/69b4c09b81daabb0ad4ea1a9be0c70307370dfac6707e3f98ecb9b759ce0/c0d4e89f983e64c363bb9d749156e618c15a52ab_main_hero_image.jpg" /><source media="(min-width: 480px) and (max-width: 991px)" srcset="https://cdnp1.stackassets.com/a79075f6f5e64037bfc720c8249a088d06ba0d57/store/opt/69b4c09b81daabb0ad4ea1a9be0c70307370dfac6707e3f98ecb9b759ce0/c0d4e89f983e64c363bb9d749156e618c15a52ab_main_hero_image.jpg" /><source media="(min-width: 992px) and (max-width: 1199px)" srcset="https://cdnp1.stackassets.com/77692805a9c4eb68ca0bde5992791e178b78bd40/store/opt/489/244/69b4c09b81daabb0ad4ea1a9be0c70307370dfac6707e3f98ecb9b759ce0/c0d4e89f983e64c363bb9d749156e618c15a52ab_main_hero_image.jpg" /><img class="img-responsive" src="https://cdnp1.stackassets.com/472a8456ab2f5d55056fe2cd96d4296956d53911/store/opt/596/298/69b4c09b81daabb0ad4ea1a9be0c70307370dfac6707e3f98ecb9b759ce0/c0d4e89f983e64c363bb9d749156e618c15a52ab_main_hero_image.jpg" alt="C0d4e89f983e64c363bb9d749156e618c15a52ab main hero image" /></picture>
</div>


                    <div class="bubble-bundle-page-product-details text-center">
                      <div class="bubble">
  <div class="title">Access</div>
  <div class="value">Lifetime</div>
</div>

                      <div class="bubble">
  <div class="title">Content</div>
  <div class="value">6 hours</div>
</div>

                      <div class="bubble">
  <div class="title">Lessons</div>
  <div class="value">58</div>
</div>

                    </div>
              </div>
              <div class="col-md-6 course">
                <h3><strong>Python Web Programming</strong></h3>
                <h4>
                  Start Programming the Right Way by Diving Into Python
                </h4>

                <p>
                  By <a class="brand-primary anchor-link instructor-link" href="#product_11186-instructor">Stone Rive eLearning</a>
                    | in <a class="brand-primary" href="/collections/online-courses">Online Courses</a>
                </p>
                  <div class="bundle-page-product-details">
  
  <ul class="nav nav-tabs " role="tablist">
      <li class="col-xs-4 active primary-border-bottom-active">
        <a data-toggle="tab"
          id="product_11186-description"
          role="tab"
          class="text-capitalize js-product-detail"
          href="#product_11186-description-content">
          Description
        </a>
</li>      <li class="col-xs-4  primary-border-bottom-active">
        <a data-toggle="tab"
          id="product_11186-instructor"
          role="tab"
          class="text-capitalize js-product-detail"
          href="#product_11186-instructor-content">
          Instructor
        </a>
</li>      <li class="col-xs-4  primary-border-bottom-active">
        <a data-toggle="tab"
          id="product_11186-specs"
          role="tab"
          class="text-capitalize js-product-detail"
          href="#product_11186-specs-content">
          Specs
        </a>
</li>  </ul>

  <div class="tab-content">
    <div class="tab-pane active fade in" id="product_11186-description-content" role="tabpanel">
      Python is considered by many experts to be the ideal learning language for first time programmers because it is syntactically fairly straight-forward and has an enormous reach of applications. It's an excellent stepping stone for other, more complex languages, yet Python programmers are also in constant demand. This course dives into all aspects of web programming with Python, and will be the perfect first step for your coding odyssey.
<br><br>
<ul><li>Access 58 lectures & 6 hours of content 24/7
<li>Acquire an in-depth understanding of Python web programming
<li>Get hands on experience working w/ Python files & building programs
<li>Access & parse the web w/ Python
<li>Manage a database & a remote server
<li>Create a basic website w/ Python
<li>Run code via a Virtual Private Server</ul>
    </div>
    <div class="tab-pane  fade in" id="product_11186-instructor-content" role="tabpanel">
      At Stone River eLearning, technology is all we teach. If you're interested in programming, development or design - we have it covered. 
<br><br>
Check out our huge catalog of courses and join the over 300,000 students currently taking Stone River eLearning courses. We currently offer 125+ different technology training courses on our Stone River eLearning website and are adding new courses on hot and trending topics every month. A subscription option is available for those with a real passion for learning.
    </div>
    <div class="tab-pane  fade in" id="product_11186-specs-content" role="tabpanel">
      <p>Details & Requirements</p>

<ul><li>Length of time users can access this course: lifetime
<li>Access options: web streaming, mobile streaming
<li>Redemption deadline: redeem your code within 30 days of purchase
<li>Experience level required: beginner</ul>

<p>Compatibility</p><ul><li>Internet required</ul>
    </div>
  </div>

</div>

  <div class="course-outline inactive">
    <h4 class="title">Course Outline <i class="fa sc-display-outline pull-right"></i></h4>

      <ul>
<li>Course Introduction

<ul>
<li>Course Introduction (4:12)</li>
</ul></li>
<li>Python Programming Review

<ul>
<li>Introduction (1:07)</li>
<li>Object Oriented Programming Part 1 (8:25)</li>
<li>Object Oriented Programming Part 2 (7:16)</li>
<li>Modules (9:11)</li>
<li>Modules Part 2 (6:58)</li>
<li>Section Conclusion (0:42)</li>
</ul></li>
<li>Basic Database (SQLite) with Python

<ul>
<li>Introduction (0:52)</li>
<li>SQLite Intro (8:15)</li>
<li>Creating Database And Table (7:17)</li>
<li>Inserting Data (6:06)</li>
<li>Inserting Dynamic Data (4:32)</li>
<li>Reading Data (6:41)</li>
<li>Limit, Update, and Delete (7:59)</li>
<li>Section Conclusion (3:18)</li>
</ul></li>
<li>Using Python with the Internet

<ul>
<li>Section Introduction (0:51)</li>
<li>urllib module (5:17)</li>
<li>urllib.requests (9:42)</li>
<li>urllib headers (8:15)</li>
<li>xml intro (5:54)</li>
<li>parsing xml (8:34)</li>
<li>Section Conclusion (1:27)</li>
</ul></li>
<li>Working with HTML

<ul>
<li>Section Introduction (1:10)</li>
<li>Web Page Structure (8:14)</li>
<li>Web Page Structure 2 (7:31)</li>
<li>Nav bar (9:01)</li>
<li>HTML’s body (8:04)</li>
<li>Comments, footers, and divs (8:27)</li>
<li>Parsing Paragraph Data (7:07)</li>
<li>Section Conclusion (1:20)</li>
</ul></li>
<li>Intro to Web Server Programming

<ul>
<li>Section Introduction (3:45)</li>
<li>Creating a VPS (6:58)</li>
<li>Interacting with our VPS (9:26)</li>
<li>FileZilla (8:18)</li>
<li>PySFTP (8:16)</li>
<li>Section Conclusion (1:05)</li>
</ul></li>
<li>MySQL database with Python

<ul>
<li>Section Introduction (1:21)</li>
<li>MySQL basics (9:33)</li>
<li>MySQL Part2 (8:49)</li>
<li>Database Connection (9:04)</li>
<li>Inserting into Database (9:39)</li>
<li>Adding logic to insert (8:17)</li>
<li>Nohup (9:25)</li>
<li>Crontab (6:12)</li>
<li>Section Conclusion (1:44)</li>
</ul></li>
<li>Python&#39;s Flask Web development Framework

<ul>
<li>Section Introduction (1:35)</li>
<li>Flask setup (8:52)</li>
<li>Flask backend setup (9:30)</li>
<li>Basic Website (9:19)</li>
<li>Templates and Errors (9:14)</li>
<li>Variables and Logic (8:51)</li>
<li>Bootstrap incorporation (9:00)</li>
<li>More on Bootstrap (10:20)</li>
<li>Adding more pages to our site (7:36)</li>
<li>Extending Templates (7:50)</li>
<li>Additional Information (9:42)</li>
</ul></li>
<li>Course Conclusion

<ul>
<li>Course Conclusion (1:39)</li>
</ul></li>
</ul>

    <p class="text-center">
      <a class="open-all" data-target=".course-outline" href>View Full Curriculum</a>
    </p>
  </div>

              </div>
            </div>
            <hr class="product-divider">
            <div id="product-details-11187" class="js-product-details row pagination-details">
              <div class="col-md-6">
                <div id="sc-product-image-carousel11187" class="sc-product-image-carousel carousel slide" data-ride="carousel" data-toughness="0.25" data-interval=false>
  
      <picture><source media="(max-width: 479px)" srcset="https://cdnp0.stackassets.com/24c689f1841871ca40175912e48c9b90fd920ec4/store/opt/450/225/ba3a31ba1af2f05cfb8c8d234fbd5c3fef8b6482243347f332eb933f3d29/bad77de2ebe492948d919a73e6c129537509c1ce_main_hero_image.jpg" /><source media="(min-width: 480px) and (max-width: 991px)" srcset="https://cdnp0.stackassets.com/41cf44e9e15cb565b203ece77439bfd0dfe0ab72/store/opt/ba3a31ba1af2f05cfb8c8d234fbd5c3fef8b6482243347f332eb933f3d29/bad77de2ebe492948d919a73e6c129537509c1ce_main_hero_image.jpg" /><source media="(min-width: 992px) and (max-width: 1199px)" srcset="https://cdnp0.stackassets.com/2af483c1c749f8e960d8fe3f999f8e995b01abd1/store/opt/489/244/ba3a31ba1af2f05cfb8c8d234fbd5c3fef8b6482243347f332eb933f3d29/bad77de2ebe492948d919a73e6c129537509c1ce_main_hero_image.jpg" /><img class="img-responsive" src="https://cdnp0.stackassets.com/b277200cc6e351f810e301f06bd215392e2ba5ac/store/opt/596/298/ba3a31ba1af2f05cfb8c8d234fbd5c3fef8b6482243347f332eb933f3d29/bad77de2ebe492948d919a73e6c129537509c1ce_main_hero_image.jpg" alt="Bad77de2ebe492948d919a73e6c129537509c1ce main hero image" /></picture>
</div>


                    <div class="bubble-bundle-page-product-details text-center">
                      <div class="bubble">
  <div class="title">Access</div>
  <div class="value">Lifetime</div>
</div>

                      <div class="bubble">
  <div class="title">Content</div>
  <div class="value">5 hours</div>
</div>

                      <div class="bubble">
  <div class="title">Lessons</div>
  <div class="value">46</div>
</div>

                    </div>
              </div>
              <div class="col-md-6 course">
                <h3><strong>Taming Big Data with Apache Spark and Python</strong></h3>
                <h4>
                  Learn the Techniques Used by Major Companies to Manage Mass Data Sets
                </h4>

                <p>
                  By <a class="brand-primary anchor-link instructor-link" href="#product_11187-instructor">Frank Kane</a>
                    | in <a class="brand-primary" href="/collections/online-courses">Online Courses</a>
                </p>
                  <div class="bundle-page-product-details">
  
  <ul class="nav nav-tabs " role="tablist">
      <li class="col-xs-4 active primary-border-bottom-active">
        <a data-toggle="tab"
          id="product_11187-description"
          role="tab"
          class="text-capitalize js-product-detail"
          href="#product_11187-description-content">
          Description
        </a>
</li>      <li class="col-xs-4  primary-border-bottom-active">
        <a data-toggle="tab"
          id="product_11187-instructor"
          role="tab"
          class="text-capitalize js-product-detail"
          href="#product_11187-instructor-content">
          Instructor
        </a>
</li>      <li class="col-xs-4  primary-border-bottom-active">
        <a data-toggle="tab"
          id="product_11187-specs"
          role="tab"
          class="text-capitalize js-product-detail"
          href="#product_11187-specs-content">
          Specs
        </a>
</li>  </ul>

  <div class="tab-content">
    <div class="tab-pane active fade in" id="product_11187-description-content" role="tabpanel">
      Have you ever wondered how major companies and organizations manage all of the massive amounts of data they collect? The answer is Big Data technology, and Big Data engineers are in big-time demand. Major employers like Amazon, eBay, and NASA JPL use Apache Spark to extract data sets across a fault-tolerant Hadoop cluster. Sound complicated? That's why you should take this course, to learn these techniques and more, using your own system at home.
<br><br>
<ul><li>Access 46 lectures & 5 hours of content 24/7
<li>Learn the concepts of Spark's Resilient Distributed Datastores
<li>Develop & run Spark jobs quickly using Python
<li>Translate complex analysis problems into iterative or multi-stage Spark scripts
<li>Scale up to larger data sets using Amazon's Elastic MapReduce
<li>Understand how Hadoop YARN distributes Spark across computing clusters
<li>Learn about other Spark technologies, like Spark SQL, Spark Streaming, & GraphX</ul>
    </div>
    <div class="tab-pane  fade in" id="product_11187-instructor-content" role="tabpanel">
      Frank Kane spent 9 years at Amazon and IMDb, developing and managing the technology that automatically delivers product and movie recommendations to hundreds of millions of customers, all the time. Frank holds 17 issued patents in the fields of distributed computing, data mining, and machine learning. In 2012, Frank left to start his own successful company, Sundog Software, which focuses on virtual reality environment technology, and teaching others about big data analysis.
    </div>
    <div class="tab-pane  fade in" id="product_11187-specs-content" role="tabpanel">
      <p>Details & Requirements</p><ul><li>Length of time users can access this course: lifetime
<li>Access options: web streaming
<li>Certification of completion  not included
<li>Redemption deadline: redeem your code within 30 days of purchase
<li>Experience level required: all levels</ul><p>Compatibility<br></p><ul><li>Internet required</ul>
    </div>
  </div>

</div>

  <div class="course-outline inactive">
    <h4 class="title">Course Outline <i class="fa sc-display-outline pull-right"></i></h4>

      <ul>
<li>Getting Started with Spark

<ul>
<li>Introduction</li>
<li>[Activity] Installing Enthought Canopy</li>
<li>[Activity] Installing a JDK</li>
<li>[Activity] Installing Spark</li>
<li>[Activity] Installing the MovieLens Movie Rating Dataset (3:35)</li>
<li>[Activity] Run your first Spark program! Ratings histogram example.</li>
</ul></li>
<li>Spark Basics and Simple Examples

<ul>
<li>Introduction to Spark</li>
<li>The Resilient Distributed Dataset (RDD)</li>
<li>Ratings Histogram Walkthrough</li>
<li>Key/Value RDD&#39;s, and the Average Friends by Age Example</li>
<li>[Activity] Running the Average Friends by Age Example</li>
<li>Filtering RDD&#39;s, and the Minimum Temperature by Location Example</li>
<li>[Activity]Running the Minimum Temperature Example, and Modifying it for Maximums</li>
<li>[Activity] Running the Maximum Temperature by Location Example</li>
<li>[Activity] Counting Word Occurrences using flatmap()</li>
<li>[Activity] Improving the Word Count Script with Regular Expressions</li>
<li>[Activity] Sorting the Word Count Results (7:44)</li>
<li>[Exercise] Find the Total Amount Spent by Customer (4:01)</li>
<li>[Excercise] Check your Results, and Now Sort them by Total Amount Spent. (5:08)</li>
<li>Check Your Sorted Implementation and Results Against Mine.</li>
</ul></li>
<li>Advanced Examples of Spark Programs

<ul>
<li>[Activity] Find the Most Popular Movie</li>
<li>[Activity] Use Broadcast Variables to Display Movie Names Instead of ID Numbers</li>
<li>Find the Most Popular Superhero in a Social Graph</li>
<li>[Activity] Run the Script - Discover Who the Most Popular Superhero is!</li>
<li>Superhero Degrees of Separation: Introducing Breadth-First Search</li>
<li>Superhero Degrees of Separation: Accumulators, and Implementing BFS in Spark</li>
<li>[Activity] Superhero Degrees of Separation: Review the Code and Run it</li>
<li>Item-Based Collaborative Filtering in Spark, cache(), and persist()</li>
<li>[Activity] Running the Similar Movies Script using Spark&#39;s Cluster Manager</li>
<li>[Exercise] Improve the Quality of Similar Movies</li>
</ul></li>
<li>Running Spark on a Cluster

<ul>
<li>Introducing Elastic MapReduce</li>
<li>[Activity] Setting up your AWS / Elastic MapReduce Account and Setting Up PuTTY</li>
<li>Partitioning</li>
<li>Create Similar Movies from One Million Ratings - Part 1</li>
<li>[Activity] Create Similar Movies from One Million Ratings - Part 2</li>
<li>Create Similar Movies from One Million Ratings - Part 3</li>
<li>Troubleshooting Spark on a Cluster</li>
<li>More Troubleshooting, and Managing Dependencies</li>
</ul></li>
<li>Other Spark Technologies and Libraries

<ul>
<li>Introducing MLLib</li>
<li>[Activity] Using MLLib to Produce Movie Recommendations</li>
<li>Analyzing the ALS Recommendations Results</li>
<li>Spark SQL</li>
<li>Spark Streaming and GraphX</li>
</ul></li>
<li>You Made It! Where to Go from Here.

<ul>
<li>Learning More about Spark and Data Science</li>
</ul></li>
</ul>

    <p class="text-center">
      <a class="open-all" data-target=".course-outline" href>View Full Curriculum</a>
    </p>
  </div>

              </div>
            </div>
            <hr class="product-divider">
        </div>
        <div class="col-md-6 col-md-offset-6 products-view-all hidden-xs hidden-sm">
          <a href="#" class="brand-primary pagination-view-all js-pagination-view-all pull-right">
            View All Products
          </a>
        </div>
      </div>
    </div>
  </div>
</div>

  </section>
  <div class="row">
    <div class="col-xs-12"><hr></div>
  </div>

  <div class="row">
    <div class="col-xs-12 col-md-6">
      <div class="item">
        <h4>Terms</h4>
        <ul><li>Instant digital redemption</ul>
      </div>
    </div>
    <div class="col-md-6 sc-bundle-page-purchase-form">
      <div class="row">
        <div class="item hidden-xs hidden-sm">
          <ng-form class="buy-form form-horizontal js-sc-purchase-form" data-type="Bundle" data-price="44.0" data-name="The Python Power Coder BONUS Bundle" data-ids="[5556]" role="form" ng-controller="AddToCartCtrl">

  <input type="hidden" name="sale_id" id="sale_id" value="5556" data-sale-slug="the-python-power-coder-bonus-bundle" />

    <div class="col-md-4 select--left hidden-sm hidden-xs col-lg-3">
      <select name="quantity" id="quantity" class="form-control js-quantity" data-price="4400" ng-model="quantity"><option value="1">1</option>
<option value="2">2</option>
<option value="3">3</option>
<option value="4">4</option>
<option value="5">5</option></select>
    </div>

  <div class="col-md-8 col-xs-12 col-lg-9 ">
    <add-to-cart-button class="hidden-xs hidden-sm btn btn-lg btn-block btn-success js-purchase-submit form-control additem" ng-click="addItem()" ng-disabled="addingToCart" data-button-type="buy_now">
      Add to Cart - $44
</add-to-cart-button>    <add-to-cart-button class="visible-xs visible-sm btn btn-lg btn-success js-sc-sale-form-submit-mobile form-control" ng-click="addItem()" ng-disabled="addingToCart" data-button-type="buy_now">
      <span>Add to Cart - $44</span>
</add-to-cart-button>  </div>

    <div class="hidden-md hidden-lg select-mobile">
      <select name="quantity" id="quantity" class="form-control js-quantity" data-price="4400" ng-model="quantity"><option value="1">1</option>
<option value="2">2</option>
<option value="3">3</option>
<option value="4">4</option>
<option value="5">5</option></select>
    </div>

</ng-form>
<div class="buy-now-fixed js-sc-sale-buy-now-fixed">
  <div class="js-no-variant" data-type="Bundle" data-toggle="#sc-purchase-form"><add-to-cart-button class="btn btn-success btn-lg btn-block js-no-variant-text" data-button-type="buy_now">Add to Cart ($44)</add-to-cart-button></div>
</div>

        </div>
      </div>
    </div>
  </div>

  <div class="bundle-page-best-sellers category-footer intelligent-modules-container">
    <div class="js-intelligent-module-sale js-best-sellers intelligent-modules-section">
      <div data-columns="4" data-title="Best Sellers" data-index-url="/best-sellers" data-entries="/v0/search/sales?exclude_sale_ids%5B%5D=5556&amp;per_page=4&amp;publisher_id=124&amp;sort=best_sellers&amp;tags%5B%5D=Developer&amp;tags%5B%5D=Learn+to+Code&amp;tags%5B%5D=Skillwise+Bundles&amp;tags%5B%5D=ALL+Digital&amp;tags%5B%5D=Email%3A+Programmers&amp;tags%5B%5D=ALL+DEALS&amp;tags%5B%5D=ALL+SKILLWISE+COURSES+FOR+SALES&amp;tags%5B%5D=Gaming+Persona+Black+Friday+2017+eLearning&amp;tags%5B%5D=Best+of+2017&amp;tags%5B%5D=Site+Nav+Bundles&amp;tags%5B%5D=Site+Nav+Python&amp;tags%5B%5D=Get+Smart+Campaign&amp;tags%5B%5D=ALL+ELEARNING+MINUS+PWYW" data-module-type="SalesIntelligentModule" class="intelligent-module js-intelligent-module sales-intelligent-module "></div>
    </div>

    
  </div>
</div>
<div class="hidden-xs">
  <a href data-toggle="#stacksocial-wrapper" id="back-to-top" class="anchor-link hidden-phone">
    <i class="icon-pushup"></i>
  </a>
</div>


        </div>
      </div>

      
  <footer id="footer" class="footer">
    <div class="container">

      <div class="footer-menus-row row">
        <div class="col-md-5">
          <div class="footer-newsletter">
  <h5 class="footer-title footer-newsletter-title">Sign up & get 10% Off</h5>

  <form class="clearfix form-inline" role="form" action="/subscribe" accept-charset="UTF-8" method="post"><input name="utf8" type="hidden" value="&#x2713;" /><input type="hidden" name="authenticity_token" value="zLIJSJaWWdEVBBs2KY6MmOpqkU9fT8PRi+FGaOsCfbww78KXgaKJKUPX22rj5aJLhGfYv1dBCUiRplm7Mdp/AA==" />
    <div class="clearfix js-mailcheck-container">
      <input type="hidden" name="source" id="source" value="Footer" />
      <label for="signup-newsletter" class="sr-only">Email address</label>
      <input type="email" name="email" id="signup-newsletter" class="form-control js-email-field" placeholder="Email" />

      <button type="submit" class="btn-primary">
        Sign up
      </button>
    </div>

    <span class="newsletter-legend">
      *New customers only. Offer lasts 30 days. See Terms.
    </span>
</form></div>

        </div>

        <div class="col-md-7 footer-menus footer-menus-vendor">
          <div class="row">
            <div class="col-xs-4">
  <h4 class="footer-title">My Account</h4>

  <ul class="list-unstyled">
    <li>
      <a href="/user?show=profile-tab">Profile</a>
    </li>
    <li>
      <a href="/user?show=account-tab">Account</a>
    </li>
    <li>
      <a href="/user/purchases">Purchases</a>
    </li>
    <li>
      <a href="/user/credits">Credits</a>
    </li>
    <li>
      <a href="/user?show=preferences-tab">Preferences</a>
    </li>
  </ul>
</div>

<div class="col-xs-4">
  <h4 class="footer-title">Support</h4>

  <ul class="list-unstyled">
    <li>
      <a target="_blank" href="https://support.stackcommerce.com/hc/en-us/requests/new?affiliate_id=&amp;first_name=&amp;order_id=&amp;persona=Internet+Culture&amp;publisher_id=124&amp;publisher_logo=https%3A%2F%2Fcdnp2.stackassets.com%2F6bb1b0c4b5b2c69fbe228a7e8ed974eb3f33579b%2Fstore%2Fc955c12e55d585985198f1ace9a068fc5460be420701cce2f5f96f447b30%2F28cfa6b9164214d3cee54b990b00d4d09781aea6_logo_main.png&amp;sale_id=5556&amp;sale_name=The+Python+Power+Coder+BONUS+Bundle&amp;sale_url=https%3A%2F%2Fstore.digg.com%2Fsales%2Fthe-python-power-coder-bonus-bundle&amp;source=lower+footer+contact+link&amp;user_id=">Contact</a>
    </li>
    <li>
      <a target="_blank" href="https://support.stackcommerce.com/hc/en-us/?affiliate_id=&amp;first_name=&amp;order_id=&amp;persona=Internet+Culture&amp;publisher_id=124&amp;publisher_logo=https%3A%2F%2Fcdnp2.stackassets.com%2F6bb1b0c4b5b2c69fbe228a7e8ed974eb3f33579b%2Fstore%2Fc955c12e55d585985198f1ace9a068fc5460be420701cce2f5f96f447b30%2F28cfa6b9164214d3cee54b990b00d4d09781aea6_logo_main.png&amp;sale_id=5556&amp;sale_name=The+Python+Power+Coder+BONUS+Bundle&amp;sale_url=https%3A%2F%2Fstore.digg.com%2Fsales%2Fthe-python-power-coder-bonus-bundle&amp;source=lower+footer+FAQs+link&amp;user_id=">FAQs</a>
    </li>
    <li>
      <a target="_blank" href="https://support.stackcommerce.com/hc/en-us/sections/202047586-Shipping?affiliate_id=&amp;first_name=&amp;order_id=&amp;persona=Internet+Culture&amp;publisher_id=124&amp;publisher_logo=https%3A%2F%2Fcdnp2.stackassets.com%2F6bb1b0c4b5b2c69fbe228a7e8ed974eb3f33579b%2Fstore%2Fc955c12e55d585985198f1ace9a068fc5460be420701cce2f5f96f447b30%2F28cfa6b9164214d3cee54b990b00d4d09781aea6_logo_main.png&amp;sale_id=5556&amp;sale_name=The+Python+Power+Coder+BONUS+Bundle&amp;sale_url=https%3A%2F%2Fstore.digg.com%2Fsales%2Fthe-python-power-coder-bonus-bundle&amp;source=lower+footer+shipping+link&amp;user_id=">Shipping</a>
    </li>
    <li>
      <a target="_blank" href="https://support.stackcommerce.com/hc/en-us/sections/202049583-Refund-Return?affiliate_id=&amp;first_name=&amp;order_id=&amp;persona=Internet+Culture&amp;publisher_id=124&amp;publisher_logo=https%3A%2F%2Fcdnp2.stackassets.com%2F6bb1b0c4b5b2c69fbe228a7e8ed974eb3f33579b%2Fstore%2Fc955c12e55d585985198f1ace9a068fc5460be420701cce2f5f96f447b30%2F28cfa6b9164214d3cee54b990b00d4d09781aea6_logo_main.png&amp;sale_id=5556&amp;sale_name=The+Python+Power+Coder+BONUS+Bundle&amp;sale_url=https%3A%2F%2Fstore.digg.com%2Fsales%2Fthe-python-power-coder-bonus-bundle&amp;source=lower+footer+returns+link&amp;user_id=">Returns</a>
    </li>
    <li><a href="/terms">Terms</a></li>
    <li><a href="/privacy">Privacy</a></li>
  </ul>
</div>


              <div class="col-xs-12 col-sm-4 footer-vendor-section">
  <hr class="visible-xs">

  <h4 class="footer-title">Are you a vendor?</h4>
  <p class="footer-subtitle">Get exclusive coverage to the world's top publisher sites through the StackCommerce network.</p>

  <a class="pub-footer-link primary-color" target="_blank" href="https://www.stackcommerce.com/vendors">Learn More</a>

  <div class="powered-by">
  <h6>Powered By</h6>

  <a target="_blank" href="https://stackcommerce.com/">
    <img alt="StackCommerce" src="https://shops2.stackassets.com/assets/core/logo-light-531c09dd9744d199c151749553ae71f8db7a185f827067726cb82077cd377411.svg" />
</a></div>


  <div class="hidden-xs pub-copyright">
    <p>Copyright &copy; 2018 StackCommerce. All Rights Reserved.</p>
  </div>

  <div class="bbb-badge-container">
  <a id="bbblink"
    class="sehzbus bbb-badge"
    target="_blank" href="https://www.bbb.org/losangelessiliconvalley/business-reviews/online-retailer/stackcommerce-in-venice-ca-1013267#bbbseal"
    title="StackCommerce, Online Retailer, Venice, CA">
      <img id="bbblinkimg"
        src="https://seal-sanjose.bbb.org/logo/sehzbus/stackcommerce-1013267.png"
        width="200"
        height="38"
        alt="StackCommerce, Online Retailer, Venice, CA">
  </a>
</div>

</div>

          </div>
        </div>
      </div>

          <img alt="Digg logo" class="sc-footer-pub-logo hidden-xs" src="https://cdnp3.stackassets.com/3cd152b6e15fd8734497708cb799013cac905773/store/7c6bb1fa8e748ae29147a733147ae02bbb82ff2b08be0d229110d3b585bd/18485477206329f39051d32ebd95fa7629126b67_logo_footer.png" />


    </div>
  </footer>

  <script>
//<![CDATA[

    var bbbprotocol = (("https:" == document.location.protocol) ? "https://" : "http://");
    document.write(unescape("%3Cscript src='" + bbbprotocol + 'seal-sanjose.bbb.org' + unescape('%2Flogo%2Fstackcommerce-1013267.js') + "' type='text/javascript'%3E%3C/script%3E"));

//]]>
</script>
    </div>

      <div
    id="email-capture-modal"
    class="modal email-capture-modal email-capture-vertical-lifestyle"
    tabindex="-1"
    role="dialog"
    aria-labelledby="email-capture-modal"
    aria-hidden="true"
    data-backdrop="static"
    data-email-capture-modal
    data-email-capture-analytics-url="https://store.digg.com/modal_email_capture"
  >
    <div class="modal-dialog">
      <div class="modal-content">
        <div class="modal-header">
          <button
            type="button"
            class="pull-right close"
            data-email-capture-modal-dismiss
            data-dismiss="modal"
            aria-label="Close"
          >
            <span aria-hidden="true">&times;</span>
          </button>
        </div>
        <div class="modal-body clearfix">
          <div class="email-capture-form-container" data-email-capture-form-container>
            <div class="email-capture-headline">
              Take 10% Off<br/>
              Your First Purchase
            </div>

            <div class="email-capture-message">
              Join millions of other subscribers who get exclusive discounts, freebies and giveaways!
            </div>

            <form data-email-capture-modal-form="true" novalidate="novalidate" action="/subscribe.json" accept-charset="UTF-8" data-remote="true" method="post"><input name="utf8" type="hidden" value="&#x2713;" />
              <input type="hidden" name="source" id="source" value="EmailCaptureModal" />
              <div class="text-danger email-capture-error" data-email-capture-modal-messages></div>
              <div class="form-group">
                <input type="email" name="email" id="email" class="form-control email email-capture-field" placeholder="Email" />
              </div>
              <button name="button" type="submit" class="btn btn-lg btn-block email-capture-button">
                Get my discount
</button></form>            <div class="email-capture-detail">
              Coupon code will be sent to this email address
            </div>
            <div class="email-capture-terms">
              By joining our mailing list you agree to our <a target="_blank" href="/terms">Terms and Conditions</a>
            </div>
            <div class="email-capture-dismiss" data-email-capture-modal-dismiss>
              No thanks, I'll just pay full price.
            </div>
          </div>

          <div class="email-capture-confirmation-container hide" data-email-capture-confirmation-container>
            <div class="email-capture-headline">
              You're in!
            </div>

            <div class="email-capture-message">
              Check your inbox for your 10% coupon
            </div>

            <button
              class="btn btn-lg btn-primary email-capture-confirmation-button"
              data-email-capture-modal-dismiss
              data-email-capture-modal-continue
            >
              Start shopping
            </button>
          </div>
        </div>
      </div>
    </div>
  </div>

    <script src="https://shops2.stackassets.com/assets/config-269b3be761327b3f955044ff15b7b65ae6e0ab34e3b050439dc5a54e608a5bb5.js"></script>

<script>
  SC.config.setPublisher({"id":124,"name":"Digg","hostname":"store.digg.com","brand_primary_color":"#00B0FF","vertical":"lifestyle"});
  SC.config.setUser(null);
  SC.config.setOptions({
    loyaltySpentAmount: 25,
    loyaltyAmountInCredit: 1,
    jetloreCartUpsellFilter: 'PROD_CART_UPSELL_FILTER'
  });
</script>

    <script src="https://shops2.stackassets.com/assets/classic-0e1a136f0bd9581584a27a0adf578e91c45c7dbe012efc81e49920c189582c6c.js"></script>
      <script type="text/javascript">
    var _at = {}; window._at.track = window._at.track || function(){(window._at.track.q = window._at.track.q || []).push(arguments);};

    _at.domain = 'store.digg.com/';
    _at.idSite = '8310';
    _at.webpushid = 'web.56.aimtell.com';
    _at.owner = '2fcd12b568b6';
    _at.attributes = {};

    (function() { var u='//s3.amazonaws.com/cdn.aimtell.com/trackpush/'; var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0]; g.type='text/javascript'; g.async=true; g.defer=true; g.src=u+'trackpush.min.js'; s.parentNode.insertBefore(g,s); })();
  </script>

    <script>
  window.twttr = (function(d, s, id) {
    var js, fjs = d.getElementsByTagName(s)[0], t = window.twttr || {};
    if (d.getElementById(id)) return; js = d.createElement(s); js.id = id;
    js.src = "https://platform.twitter.com/widgets.js"; fjs.parentNode.insertBefore(js, fjs);
    t._e = []; t.ready = function(f) { t._e.push(f); };
    return t;
  }(document, "script", "twitter-wjs"));
</script>

<script>
</script>

  <!-- Quantcast Tag, part 2 -->
  <script type="text/javascript">
    _qevents.push( { qacct:"p-443uI8zl5eTMM" } );
  </script>
  <noscript>
    <div style="display:none;">
      <img src="//pixel.quantserve.com/pixel/p-443uI8zl5eTMM.gif" border="0" height="1" width="1" alt="Quantcast"/>
    </div>
  </noscript>
<!-- End Quantcast tag -->

    
    

      
      
    <div bundle-club-modal visible="showModal"></div>
    
  </body>
    <script>
      var event  =  'SCDataLayer';
      var action =  'BROWSE';

      SC.dataLayer.enqueue(event, action, {"event":"SCDataLayer","action":"BROWSE","productId":5556,"productPrice":44.0});
  </script>

  
</html>
